summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-11 12:21:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-11 12:21:25 +0200
commit1b85f5be41be722d8e19348a7c270352aded0bb4 (patch)
tree754dc8ce5a14cad2b0dc796579968bad05e8e0ae /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.2 (diff)
downloadgentoo-1b85f5be41be722d8e19348a7c270352aded0bb4.tar.gz
gentoo-1b85f5be41be722d8e19348a7c270352aded0bb4.tar.bz2
gentoo-1b85f5be41be722d8e19348a7c270352aded0bb4.zip
dev-python/boto3: Bump to 1.28.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2335251c291c..21e070639cb7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.27.0.gh.tar.gz 671636 BLAKE2B 1a3927db8c67b066108b03a9018522b73f6b2
DIST boto3-1.27.1.gh.tar.gz 672067 BLAKE2B 63bc6fcb40c3623d84cdd5e21cb656f7ba0335e06c45c7ffe652bece36f7bbf0ddaf4d52b98625d31851b63f646abecf79eac727a35a31e6f58410def3be4289 SHA512 e3b339459a2ae221d8aefb4c540bfae6ec9fc5ec27b623c66d894aef5e50873b57ed6dd12b356b32a4c30aef3e8d98c4c43bbbb629033c850604ef2bfa6cb715
DIST boto3-1.28.0.gh.tar.gz 672952 BLAKE2B f648cb49defe36b40138dfe3c125e15bc6480d2e36dc78247c173c766f37a4a679a8d11097b44785cc2ab6c0262b3bd874fdf95f7d4e51ef54dbfa990fb05293 SHA512 312ef8fe9f399b9e79a8fa75668c567fe711ab7ce8de8e2017dd147b477579aedeb0760efcfe4d1ce9dc106a0e4f09ea6126a9571dfc6d4ed78aabbba7ee7153
DIST boto3-1.28.1.gh.tar.gz 673678 BLAKE2B a4f92be4cb7256d37483796a71297bfc01c32c33fe50c54d32398d8227b466b1c6a4ef74c4a26a58a4abcccaeccd64a7faa0d85526d9dd2b33f0befdf48593c8 SHA512 5f7f2c3cc282046bb9660bfac7f176622ea239bc724c8c47c981f92b023598fca564db586d8733a46f3a6037ba85b0cc1f9a8b7b79797e6c3d46f0ce368861e2
+DIST boto3-1.28.2.gh.tar.gz 673872 BLAKE2B 9f8a3e299cb6df278756ddafee0956b99ac9db63ff8eb2ad7bf6810e3c4140f6512a7de9963e6a7ddb065affb171d92f1f05226cba7a1e4037464e530d7e536a SHA512 062b5c70079acd5a9b3a0e4f23d44fe9f05f27e621951484e557a852d797c25c590a0ed545c2772326cd0d255cdb56250db2a2544c938f75dccc81a5f6e1d678
diff --git a/dev-python/boto3/boto3-1.28.2.ebuild b/dev-python/boto3/boto3-1.28.2.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}