summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-23 07:20:47 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-23 08:09:47 +0100
commit2cc9580de1e7099a2b6efcb4fab55b7310b3ed4c (patch)
tree0caba8e09639a42b43c228d167a04e56507ff2e1 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.68 (diff)
downloadgentoo-2cc9580de1e7099a2b6efcb4fab55b7310b3ed4c.tar.gz
gentoo-2cc9580de1e7099a2b6efcb4fab55b7310b3ed4c.tar.bz2
gentoo-2cc9580de1e7099a2b6efcb4fab55b7310b3ed4c.zip
dev-python/boto3: Bump to 1.35.68
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.68.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 7057f7afbc22..96caee2cf5a1 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.35.64.gh.tar.gz 892807 BLAKE2B bf2b899bfa3163efe20851079e764d99ccaf
DIST boto3-1.35.65.gh.tar.gz 894025 BLAKE2B 378eef8673f3ed9a6d1495d0c4182679edb7671bd358d6041cba955a7a59954a9f516dfe371080926da669c14a4d47179ed22ffb326fb60ac6782e4d4f6963f0 SHA512 ad2335b0b18915971f49d44249d87808ed7b70977b30894070df941e3a84d9acb215f95ed7176f97faf8a9065c039ac0919dd8500114f1cf2d55169fb989d5e0
DIST boto3-1.35.66.gh.tar.gz 896770 BLAKE2B 734980f82893d889fce0dadfd753f2be84390fef6d1d482c36b913ce02f5e189440c83eef8d94a34195289dc5246c244498f994b8be7ab439a66f32a97991c1e SHA512 a2fba42ba874fa829048f1579dcedba0eb8405a1d8474c90ebb941d44a575ac5c08f5830e2548fde37726dee279eea403ec8d894c28af1a67dab44af2ea4074e
DIST boto3-1.35.67.gh.tar.gz 898885 BLAKE2B 2d9cdc0e78bca1ce3301c309d7f9db0dcce310300de2995101ad7a6200066a9e8a3313af96be0256832e01620329bf48182f244faf2558bad98d4217f81cd08a SHA512 e8f7b08391cb26b73faa3cf72b88a996774e8c18694784710481b4203cd8b75ec00ad8fe8bab724c42265514e18d77c4880b7e9a04a21e7d58be473b500962df
+DIST boto3-1.35.68.gh.tar.gz 901189 BLAKE2B f7449998af169c873319d7b8748035db72c3af7be6499453c9fe61f40cbfd724dce7cf003fe700f6046f43c887768f4c26dd52e491f5734a5ec55c5b54e360c0 SHA512 24582ed20764870e2491a2dc48869089ebc4371a279eff68827ce3a6a962568fc1738e52285fa89a3a846385b498bb233460c1d0ae3177d735ad20b2cef7fea2
diff --git a/dev-python/boto3/boto3-1.35.68.ebuild b/dev-python/boto3/boto3-1.35.68.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.68.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}