summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-25 08:20:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-25 09:07:07 +0200
commit3556e434f50665ce2ccf5b820fe95634ef27e7a7 (patch)
treee44b07622cd90c8adf4dc0a68a22036cf57f1923 /dev-python/boto3
parentdev-python/pebble: Bump to 4.6.3 (diff)
downloadgentoo-3556e434f50665ce2ccf5b820fe95634ef27e7a7.tar.gz
gentoo-3556e434f50665ce2ccf5b820fe95634ef27e7a7.tar.bz2
gentoo-3556e434f50665ce2ccf5b820fe95634ef27e7a7.zip
dev-python/boto3: Bump to 1.18.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.28.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 0ff4fe883d22..ca4db4964397 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.18.24.tar.gz 404333 BLAKE2B fd0857a3462485a8cb633888ad6cae1578f32f7
DIST boto3-1.18.25.tar.gz 404826 BLAKE2B 629a7c76ec4125c93a57f5e103d0b6e5fe360038bfc73a87369a035b321b6b143cc61fb2092f70f2dc6b07f6444180e64cafeb2e31a8f1e73b195abe06979c52 SHA512 a8f2c1a6248a75f67848bf75970535c71c098bb326ab9e344d7ab53e02562383be7acb0b41a18bc031459e0751e62bf29c3db17242ea4ebf0d7f88636251872a
DIST boto3-1.18.26.tar.gz 405107 BLAKE2B b851a4358fb2b7cc6a6468f09690ebf91e0348e7bbc878fbe403d8eadf023601673673aa62841a94045e55fac353bc632e419afd2483e124798477e0325a86a6 SHA512 941f41639c551b9ea140a003d215c87e209e0933031cdef717bba406a6957266447e8532aef00069c3e5e482b999c094eb89c9f2df084ad7154724b6d3ab3158
DIST boto3-1.18.27.tar.gz 405813 BLAKE2B d3da4db8133c9ad7b979a6a765f0f6d7d72e558b31753b4cef376123dcbc3964a315303fe7205d382abd6ce42bb3afb10e867908e9567c36703c94ec0c44c027 SHA512 5e29a58e898b5d6a3b0e20669c4a18bef788b8856041d0c8e8fcaa603de167c7301db1eabcc11d326f0d33fd7b7ab8b408b804cf763667d6313df1e71d0210e4
+DIST boto3-1.18.28.tar.gz 406268 BLAKE2B 1379f65f46f287a541b098b3ae183bc7d0a6c40a58f6241d97ce39ffdde4f0655e755fe56890fda767b57c6cf7bd565d95745dbbeb80f42f729f561f6e8d9a82 SHA512 98c0d94dd4971f833677947dbfbdcd495a26fda60592130842cf2f22b8929c6f72f971294d9ddc4923372706bf7f37d3d4cb0ede32afc6955d8253c19ddab63f
DIST boto3-1.18.7.tar.gz 395640 BLAKE2B 6a9fa1dd55644806fe93271805f35fbe0c4cb65d1de08dded2d2f57fcefa96e32c4ebe7b60743c52c0898222bc06d33dbd03d304bbef327b88022450a7943e2c SHA512 20e7fedab7d061ab02f391e9baf36cb554e7f194f38d24d5a75f76715b2acf1b51b6adce5d8cf5a2a0d29df73566db00b8813a219d45a194d9a8eb93d0dab570
diff --git a/dev-python/boto3/boto3-1.18.28.ebuild b/dev-python/boto3/boto3-1.18.28.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.28.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}