summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-27 07:38:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-27 08:15:16 +0200
commit4295d9b49fe195c5a6e8c1b11dba527c5e19f57c (patch)
tree8bebf99d57b021925f14084948ec7e12e5eba283 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.28 (diff)
downloadgentoo-4295d9b49fe195c5a6e8c1b11dba527c5e19f57c.tar.gz
gentoo-4295d9b49fe195c5a6e8c1b11dba527c5e19f57c.tar.bz2
gentoo-4295d9b49fe195c5a6e8c1b11dba527c5e19f57c.zip
dev-python/boto3: Bump to 1.35.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.28.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 871a22508956..b7c35226a172 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.35.24.gh.tar.gz 864653 BLAKE2B e2327ae352d17f0cfabdcca6d7db07e0212e
DIST boto3-1.35.25.gh.tar.gz 865483 BLAKE2B 606bff8b084d3b0cd7d773cf840bd817861eed4a832c073f10e90bbfffcc7ca44b05d442131da4b4cc1696bca79e389bc00d78be1d3bc2b593ef3682bea182dd SHA512 71f732bf22ea76f9e364a3a57a1f9b2d7cdbeed28cc951a6a9930d3cfeaeb9086aece0627f34e8223ff100a7607bfd3ea8d97f5a19b504a95bcd4a14153c9878
DIST boto3-1.35.26.gh.tar.gz 865822 BLAKE2B 72df9bc9f7324ad398ef91385fe5ba3ed0349e0d5f8dac6a0e529c7065d74ea4b2652017cae759005b8a332d9b3f868d78b3ca51df3ba172e3a9cef3d568359d SHA512 8f514e09f4e6f12974ac3b85cafd88e0648760d24245fa6ca382b9cd1283b2d03b7624e50bc05589e66bf3ab076ed53743da129746d2ecd7bf41c7114a91b4e5
DIST boto3-1.35.27.gh.tar.gz 866042 BLAKE2B c3cd56e9139843f4633a81d8be04bd667071a318deb12fddf9da349430c1931d25c22ce745f7f5f354babf6edcf7e9d1d34356fda42d1ade3bb39a34ebc5b7ce SHA512 5143cdaf05d2188f45e39f50f68d45cf656122a4f5c9093fcf8f0c8f94ece4e7a82775cf37097e7f1a81535660d8c678be943bba54a027c37323512508456e11
+DIST boto3-1.35.28.gh.tar.gz 867165 BLAKE2B 92b1526b8a9755c2f8f60ed5be23154b410489581410744e000913a63a32d5e960757766dab9ba8426c5eccbad2da6d4cc5bc19550e825f5300a01f2252830a7 SHA512 11d7009c5a938d3b722d158259eebf52e023a9fb67c48b2260c63740b297b1ed0ead75adb27a7a281d83fb5b935535f09c979e71aad08dc53143ce9d3caa3a79
diff --git a/dev-python/boto3/boto3-1.35.28.ebuild b/dev-python/boto3/boto3-1.35.28.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.28.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}