summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 03:24:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 03:26:45 +0100
commit6a774720ce2e5a6300ed4f46bb073006b668dd1c (patch)
treec153155558bec6318e368f5e03755e6b3de9e466 /dev-python/boto3
parentdev-python/botocore: Bump to 1.29.92 (diff)
downloadgentoo-6a774720ce2e5a6300ed4f46bb073006b668dd1c.tar.gz
gentoo-6a774720ce2e5a6300ed4f46bb073006b668dd1c.tar.bz2
gentoo-6a774720ce2e5a6300ed4f46bb073006b668dd1c.zip
dev-python/boto3: Bump to 1.26.92
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.92.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 915a16e5d4cb..bcec4096b974 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.26.88.gh.tar.gz 615353 BLAKE2B eecc0bf96a8f6eadc2337de0a29f993f0a7e
DIST boto3-1.26.89.gh.tar.gz 615718 BLAKE2B 3257e6efafaf139daf935385c252c10929be2a4277a8f0f192afc6dbd7cc32fa8f940a4e59ebbe25931c399dedb926a3c1848bd9cc0a7f0d377acb302eabe3b0 SHA512 02ee02b05023e9184f779ab8ff21afa6f7e56f7d2e883d021b2567676c5fc57cad6b475d55316a2017c2a837c41d2f5604824f440060e2f96804c5a61ccdd143
DIST boto3-1.26.90.gh.tar.gz 616132 BLAKE2B 1c6fb20ca08c75fce5bc192cd49c8540fb5a702790f5abcdcafd4ee803e4967e55c97a99214cfae57701e6f808501d48e3bf3b5c73e1737ca3f3909af2522d4d SHA512 da438af104c3362e366785da71b9892f45b2238d280c0c39df27572afc076d4535e73fe58aa7cc7fb565b92ed8423938ddb0f16e3a5ed641231e5efadb1bf0b5
DIST boto3-1.26.91.gh.tar.gz 616798 BLAKE2B 51e61db07beeb39d8fc4be88818a13e259bc71fe25d1a52df10f7ffb364ca5d42509f4cda526fa1eb41e97bb6db1a453ab8865d8032b279523c3a994ca28bb7a SHA512 e1bde413d836ae5e3332e84a73c2f687b0d6800dcaed16ef24354f95a5e39995aeeeba3ca4a82158a7752e1cfd61fb6e39c301d9156b94e021ec0794463d1f90
+DIST boto3-1.26.92.gh.tar.gz 617090 BLAKE2B ce559b42c3d1e0d0d79444d7c86e9b6451c9419625bc54ffe816c662df886169e086f2389acfa3e9c634c292eda186758e14df492deb06d09e077e750c350150 SHA512 8ec2b0f5d9b605d9e62ccaad442b6caeef6d0ba1f8b65e5276c96d9624e14e934391cce83619f68dc57c8c46b41d187521fe30aae19b6159dc69888a26ead10f
diff --git a/dev-python/boto3/boto3-1.26.92.ebuild b/dev-python/boto3/boto3-1.26.92.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.92.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}