summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-23 05:07:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-23 06:12:26 +0100
commit82ebe70eaeb04c1cd1f8c02f599a84301e071e79 (patch)
treec61ca31b068bea5aa40c14c267e3aa8d59497162 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.7 (diff)
downloadgentoo-82ebe70eaeb04c1cd1f8c02f599a84301e071e79.tar.gz
gentoo-82ebe70eaeb04c1cd1f8c02f599a84301e071e79.tar.bz2
gentoo-82ebe70eaeb04c1cd1f8c02f599a84301e071e79.zip
dev-python/boto3: Bump to 1.34.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6a582a9bfdbd..9c8e7b3c55c5 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.34.3.gh.tar.gz 756507 BLAKE2B 030c01e76b2d52bd2b0f95eb5065cc28410f7
DIST boto3-1.34.4.gh.tar.gz 757310 BLAKE2B 987970d34b895d8e9430219ac52de1a9e3f8100abd816a3c69d906a94b550cb027419fee1b23ab9e92c2ddb48432d596f397ecb48656f4879744417b221b21d0 SHA512 57c12bb2c8158ab2af3d54b008c962e2e4e5f696da7c9c93447fae898007a5341c5f717204c03202e81fe1f72fa5650ce645189f2ae92f7e69fb405248d12aaa
DIST boto3-1.34.5.gh.tar.gz 758144 BLAKE2B 6d73d92658d4a43cf8f243da148cc6da36e0915fd23dacaf8a780e9ed2d5ad15987bb67e25bab4337ef0800c7e1ba61be9e05f1e309c78741fa6a471179af731 SHA512 dc4c543b40ebb82947adb40eee0d8e6d0378dcb0f0723fbaac3ca5222fd2cd971509af51258b5f02b70519c28ac39d7ba8211d2c3edc3ad838d1d3cf71cb56fa
DIST boto3-1.34.6.gh.tar.gz 759362 BLAKE2B 1f1b26e1ddd31be44311a9fa348765f03e6303b9556620e9437e0f10ae3c5bb6dcf09940e30823d716cd95e917c90583d7736776237726f5582eba342b4f8d4e SHA512 2f5834701fa94da9e3da97834b5c07555dbcbc2d7f1999f68301174fd1c173cdce5a6cf16ace7ed0c9b53900ac248f7d22962350294976e61d44d7f9c6164f63
+DIST boto3-1.34.7.gh.tar.gz 759909 BLAKE2B 059228d7bd57ac34274437f77b3510dff6dca7d1293ffd6f7672b0fcc0acefffeeda2c5c2b4e19ef49bbffd4746dc226edfba52d57f5f8629516c9e830dbdd90 SHA512 43395937977ad3c860ede35d2adbb9575312ddab4972b8d258e41a7d6e86f3e6a74037dadb0f0e0f4f3d5ed715a66390041ac9c980bc8a3cfb727a44e252113e
diff --git a/dev-python/boto3/boto3-1.34.7.ebuild b/dev-python/boto3/boto3-1.34.7.ebuild
new file mode 100644
index 000000000000..a61cfcefea34
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}