summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-18 07:34:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-18 08:27:19 +0100
commita0a500bd674a587d09c921d9d4ffac70c13a159a (patch)
tree8298a9cc9b44d3720b47d0018997c01b5608f3fa /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.83 (diff)
downloadgentoo-a0a500bd674a587d09c921d9d4ffac70c13a159a.tar.gz
gentoo-a0a500bd674a587d09c921d9d4ffac70c13a159a.tar.bz2
gentoo-a0a500bd674a587d09c921d9d4ffac70c13a159a.zip
dev-python/boto3: Bump to 1.35.83
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.83.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e9d3c55eeca8..1c3cefa502e5 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.35.71.gh.tar.gz 903019 BLAKE2B 48bf56c54a8eaa52c1850078a92cef7e5acb
DIST boto3-1.35.76.gh.tar.gz 910113 BLAKE2B 3e7429976b348e29ba4184bffe03c643b85dd978cc520b924263e8430b5e5935b95152cced2f6c0807c65de4e6e1405c55bb24565ac5bc425292e9adac178c03 SHA512 132f37e77b7b36d525e9cf678fe2f624eed77a9eb9fa8e7d7f079a362e5d7a5f3edcd17c7d8bc1e27570171927d26e74a94d267a1b0cbddda3890ac6a0f21cdc
DIST boto3-1.35.81.gh.tar.gz 913534 BLAKE2B aab88ae95d4c93c8f54042ef2b3ec9defdafa4d9dd4dfb57ff1da896254bbc0d1ac8c4583b8870cc8cc814366f9ef79d67d69d45b0f373878d1c22dba465e523 SHA512 fcbc31295a94983620405dbaa0f32eee2149619cf113658c2955fe84ca541cb93e8d6d637d8d7b322e6b7252bfc390b4aff77b99af3978267c64cfa5effef1f3
DIST boto3-1.35.82.gh.tar.gz 914286 BLAKE2B e2d9daaad1e89534de2fe44e107c0c49b4699ae3e69b2d67d121f97fe69ad15601333d5b9da34afd81b5f67b1fe0d1ae7b7cf982c11508597f08bca26960ef04 SHA512 23913c072c5c375be558dfe67fda2d70539a5816b9ac611ed3c11cc6cfb41372c64ad81e324f74053254e2b0996cc695e4df917b8e5a98519530defeb8f94139
+DIST boto3-1.35.83.gh.tar.gz 915295 BLAKE2B ea2f3f5c233a9f6c718bd3aa15ce5cf3c28a839f5227c6cd81b3979618d1a5c2893fcb3e05512d632f74c2eeef48713abd430d8c896ed50892f2ca9a7da2629f SHA512 57a883a0d726c32d40f0278561e0616e2f22428bde9bbe1906bb15924171258019549aad1bdbf42042d6b7fa847b99e5ba1f4be0066a720455228b4685040e84
diff --git a/dev-python/boto3/boto3-1.35.83.ebuild b/dev-python/boto3/boto3-1.35.83.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.83.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}