summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-05 08:53:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-05 09:30:55 +0300
commitb3150fed9ea01312cda2dd31b3f509b1a581daf8 (patch)
tree79cb08881aa1913ee0398ceca810cc778941624e /dev-python/boto3
parentdev-python/botocore: add 1.27.46 (diff)
downloadgentoo-b3150fed9ea01312cda2dd31b3f509b1a581daf8.tar.gz
gentoo-b3150fed9ea01312cda2dd31b3f509b1a581daf8.tar.bz2
gentoo-b3150fed9ea01312cda2dd31b3f509b1a581daf8.zip
dev-python/boto3: add 1.24.46
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.46.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 33908360097a..7143052ec5ac 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.24.42.gh.tar.gz 523969 BLAKE2B f8f802975f05246da85d5c1feafed0fbf612
DIST boto3-1.24.43.gh.tar.gz 524913 BLAKE2B f3a04f7ddd2b9b4cb9ca0c12a1306797d8bd96a459049f5fa0cf504a4d48afd5d83ec72f8c7bd6c5b3255bfe0d7ca0948c44c7a963c20773c4b04564167b6007 SHA512 b69eff403ffa4ebabf724168b664078d4e77f79f259f3bb2fbc7403067d5c0b7ad2fd067b6cd6227ce7289a25b16afd7a4ba219a18c2c616f3a266b2fcbe693d
DIST boto3-1.24.44.gh.tar.gz 525172 BLAKE2B 4fa8156a119f66bbbee29610daf6e8c6c946e1ce31d2058945f22116523cb21b9ee924b2b013fd212c93fde6c2626cf7363025a8f5547717db37f884a407b7b6 SHA512 0db4e2f664bb123a4aa5ff57165d5fc70650f8a73fd1014eb760971d8df0c02d7dddec10a4bd677dd917f38c4c8be448343aa48ade964b3168a4054c7b8bd7b2
DIST boto3-1.24.45.gh.tar.gz 524634 BLAKE2B 5b8b38efe86b30084e2071061de24744cb255cdf10ad00d872e6bcf476885f41d05f2dcbe0918fe4afbc167fde6a434782539b75fda897eaa5ebe3f33be93adb SHA512 1a89d0034a9dd987d79456f3e1baa1c26a0269f93f3fe8577c2e76a78c556e2bfde59f06bd35e8735466df3d82ce2123bf95f3291f07f6b520c7a0ad4b126fca
+DIST boto3-1.24.46.gh.tar.gz 524945 BLAKE2B f26235fb6993a9dd09fca562315c8ec7003f122fe63851eb7e9db47519b311557665998ba61dafbebcec825ff0b5ff55d329dfd41523b90a387bf590e6205eda SHA512 922423beac0f7ecefb44c474ba8a928f3faec0adc945fd06958c9ffdad612bbb3d0be9dbb68249bcb6cd12446f858c208346808239f37153e6631defb74189bf
diff --git a/dev-python/boto3/boto3-1.24.46.ebuild b/dev-python/boto3/boto3-1.24.46.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.46.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}