summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-31 05:29:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-31 05:29:49 +0100
commitb69e99b7973a523734015b4a0868e9cfe302a468 (patch)
treed43a0ed2d26405f6171840eda5d45c9af24178b9 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.52 (diff)
downloadgentoo-b69e99b7973a523734015b4a0868e9cfe302a468.tar.gz
gentoo-b69e99b7973a523734015b4a0868e9cfe302a468.tar.bz2
gentoo-b69e99b7973a523734015b4a0868e9cfe302a468.zip
dev-python/boto3: Bump to 1.35.52
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.52.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 0a778784b6ca..fcb5d6f6b0fe 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.35.44.gh.tar.gz 875230 BLAKE2B 68c4fa6739a5d9cb720670a1bc14079ffac4
DIST boto3-1.35.49.gh.tar.gz 878577 BLAKE2B 8f9ddf29eaad2f91a9ba670b268ac987f7f813dea52427a559b245111042f84b8593158bf1f3dbec353b9fb92116be39e739326dbdd70366589ee507a994da4d SHA512 3a1aa9bb8c8aa384abdc2a139273364c49f608921ff9c4ce9e96b4b93d11bb145a45ac65df6245912ba3be6d4e8f0df86e407d74610837b149f81712529b3152
DIST boto3-1.35.50.gh.tar.gz 878776 BLAKE2B 23b43830c16657e688bec46b65ae784fa8f70c5849f809bf71a4ab73533d43efd76a56bf0694d99a488bffed42896f034fe0b4680705093bd59d0dd86904c721 SHA512 91b66821f5698f09ef61851fe8419cfbe2b85f1a586858a490d12ef63ef2309af76b5393aeeb3a6b31a74a1d2dc46712750fe4b75dc627dc55fd681a5b019edf
DIST boto3-1.35.51.gh.tar.gz 879889 BLAKE2B 02e4a1713aa5112f4f8aa04b92c07748b1a4e5810ebac8ee62bd7f472852d77f3346106ad969e88cea9a9d0698268df1e7085a151000d2c6fa5efa424e21a829 SHA512 c4a733332ab77fd3b58a679e72893c2ef92e6f995c2993adca51423d5520b2fbf3febf6b97c4bcb6f341b55ffa01c19782b8aa9c822f8a5bc6012cd13c441b0b
+DIST boto3-1.35.52.gh.tar.gz 882473 BLAKE2B 486214a218babb62eaf4df54e3df5521cea656bb7246b8b7f1c5ecbdd73724b1340c31f7211c962d91875fa434f210bc0866baad79b9e3c2495ffc600a6756c6 SHA512 981801e059640ffc57711b643b5bb52bed7dd8a0f1015b96b298cd817a2d65937a0e6a8a070befafc819eb2babb0819e2144223d075495507fcb75fe76af8d3a
diff --git a/dev-python/boto3/boto3-1.35.52.ebuild b/dev-python/boto3/boto3-1.35.52.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.52.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}