summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-14 07:20:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-14 08:36:37 +0100
commitcba513b4fd58410dd8d73947aaab4efe7a9cb325 (patch)
tree4fc9318a16c657316f135954a26ca534e62ec0f5 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.81 (diff)
downloadgentoo-cba513b4fd58410dd8d73947aaab4efe7a9cb325.tar.gz
gentoo-cba513b4fd58410dd8d73947aaab4efe7a9cb325.tar.bz2
gentoo-cba513b4fd58410dd8d73947aaab4efe7a9cb325.zip
dev-python/boto3: Bump to 1.35.81
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.81.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 545746d14ffd..be438281e74b 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.35.77.gh.tar.gz 910574 BLAKE2B a843c871e53069a7a3c818e326ea5c32d506
DIST boto3-1.35.78.gh.tar.gz 911245 BLAKE2B 2afcee97ef800b934c7f5cc2046831cb48b277951f77dc9aa844dfae4e7f9fc33b36b9d1e58a727485720ffd66ce3440c7f6d103e771b43ac355634110b14d88 SHA512 d73db44fdcdeb7d82e755c1b66084d7e47884c880e615b537f9388a9dda97d8e825613567f7ce94eb5972880b790fe841ca3765c8689c1387ec69dc0cba667e7
DIST boto3-1.35.79.gh.tar.gz 911885 BLAKE2B 5b90aad921a6bd46a9bd2c1d08f12d68869ac1b8b0a7b8888b7f15ce58d25d42a9f7814b70e6453a1e84d578db1ef4f3b08940c555d11288a6b0e20128881035 SHA512 ebdb3627cd78e844635a5c0a043793aef4e2f06a3f1f220dfbb1796db9391eb84ec1248ec701075ae2660a18eb5895b26d0f0ec5fb8c4ad18f29d0feae6fd756
DIST boto3-1.35.80.gh.tar.gz 912739 BLAKE2B 636a41f4e7cf4db59e9b121c49366e7936ae1e1465f4984dffcc3b3c7a6c7b36d08c816d71c4952baeba1d0ad7ffde2f5275fd34e11ecb24856eb3645e77a729 SHA512 f6d76c76c13e0ab8f02d9056192b2bc01b18e244dd33260b38b42c56fe8ec7e7a35fe80397ec7ea7baec348cd3ce60a0182a3e0b2d202049fa1336e6d0f56a48
+DIST boto3-1.35.81.gh.tar.gz 913534 BLAKE2B aab88ae95d4c93c8f54042ef2b3ec9defdafa4d9dd4dfb57ff1da896254bbc0d1ac8c4583b8870cc8cc814366f9ef79d67d69d45b0f373878d1c22dba465e523 SHA512 fcbc31295a94983620405dbaa0f32eee2149619cf113658c2955fe84ca541cb93e8d6d637d8d7b322e6b7252bfc390b4aff77b99af3978267c64cfa5effef1f3
diff --git a/dev-python/boto3/boto3-1.35.81.ebuild b/dev-python/boto3/boto3-1.35.81.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.81.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}