summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-21 07:55:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-21 09:11:01 +0100
commitfd8e95ed90ff32a612a394eb3734f1e7523ddead (patch)
tree9317608e6d0c5d3a7e772891f61e4291640db2b7 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.86 (diff)
downloadgentoo-fd8e95ed90ff32a612a394eb3734f1e7523ddead.tar.gz
gentoo-fd8e95ed90ff32a612a394eb3734f1e7523ddead.tar.bz2
gentoo-fd8e95ed90ff32a612a394eb3734f1e7523ddead.zip
dev-python/boto3: Bump to 1.35.86
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.86.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b1df0df7c1f7..c468d504b6be 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.35.82.gh.tar.gz 914286 BLAKE2B e2d9daaad1e89534de2fe44e107c0c49b469
DIST boto3-1.35.83.gh.tar.gz 915295 BLAKE2B ea2f3f5c233a9f6c718bd3aa15ce5cf3c28a839f5227c6cd81b3979618d1a5c2893fcb3e05512d632f74c2eeef48713abd430d8c896ed50892f2ca9a7da2629f SHA512 57a883a0d726c32d40f0278561e0616e2f22428bde9bbe1906bb15924171258019549aad1bdbf42042d6b7fa847b99e5ba1f4be0066a720455228b4685040e84
DIST boto3-1.35.84.gh.tar.gz 916194 BLAKE2B 7a6a5f0d3a09ab06ebfdb8b61e3752194d22fab9fe446d0cffed786266559c1619cfded9f566f3fbf20e12816304c8b09a83fa5ecf5e3c4260b498a294109e8a SHA512 a278e7b451b4adaeea7b63792c5c1ffa8d6dbe2cf4225770cf6371a55b66614b50b8d24478cda8380886172425c780ea08fc9182ee0997561fe626c01e0a774f
DIST boto3-1.35.85.gh.tar.gz 916781 BLAKE2B dc0149b60c15d42e4e4d951dfdf414d00babe413318ad5aa726c1f0eeb669625b9aff8b25a6d95dd938a9c6032da5871ff1ebc5142bf50a5a539393d09446673 SHA512 02cfcc7b0d913944352a944711a1d844f4101c2e6a1e826b14bf1548928f06962d708f002d7fd3c6bbc42a9cf6134ccfffdd15764d81255c94a30bc37f7ca78a
+DIST boto3-1.35.86.gh.tar.gz 917880 BLAKE2B 9ebf2ff2d8674013f6edead87ff92c649e977ff942fd50dfe80da4ac7a00f812735ff38791e5572b442524d335a838f4cb16fa0cc2bf54e51ef5932cb4639bf2 SHA512 4daa945a64381aca49175211b40893bf05ec733a92ab8b972c3c3e53cfd29ac8ca142c7903ee49ba75097bdf10f7a7b36d35ff0f8cb1501b12149c9f6dffdb65
diff --git a/dev-python/boto3/boto3-1.35.86.ebuild b/dev-python/boto3/boto3-1.35.86.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.86.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}