summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-08 00:34:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-08 01:11:14 +0200
commit290842c9d8746b66977e3d9d68c2279b2fb042e4 (patch)
tree17bb16baa3117a1254e95e2cb723b6095c2a4435 /dev-python/botocore
parentx11-wm/xpra: Drop old 4.0.6-r28363 (diff)
downloadgentoo-290842c9d8746b66977e3d9d68c2279b2fb042e4.tar.gz
gentoo-290842c9d8746b66977e3d9d68c2279b2fb042e4.tar.bz2
gentoo-290842c9d8746b66977e3d9d68c2279b2fb042e4.zip
dev-python/botocore: Bump to 1.20.47
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.47.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 80243d819b0a..3bcf932a9a5e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,3 +10,4 @@ DIST botocore-1.20.43.tar.gz 7595391 BLAKE2B 78c7e146e2a5b204c5a4c0b6c0d8ea6ee8b
DIST botocore-1.20.44.tar.gz 7596878 BLAKE2B 935d4ea1c5212d29566c3344761b00d2eb03e7588bd7805072926ecd41f0fa03cd91e25802dc63078190c49f1b8503545bd0b2a88d702c04a961d57a0022080f SHA512 eb7ae15bac4ae8ad516ebcd8166f65a809d7d02c11dde25b714f7bf673ecfeef9ea414ab4b53ac428ac948ee8b054666ba2f6c0a96e6d148ff46d94e6100350d
DIST botocore-1.20.45.tar.gz 7597127 BLAKE2B 64023be1da8b10ab29110fe626ba641e9da48a47db663c2e17ed8f590b448d4fab07d66cbb68485cacaed556f27c48e12a8b2d7aa6053fcff921e4776f8a9db8 SHA512 2a3f97e4f1046aa4df3a5da9d3722579dcea0937807d9115ec5480e243788a31c58d10e1b4e002cb43668adb75174d9351cbf6b52edc0a5970c7d4b10691b02c
DIST botocore-1.20.46.tar.gz 7600596 BLAKE2B 31d81b6ae5ed9a4cf61d81151216bfb49badefce1eb56ae65ead25219044483753e6216883c50602efac336c7d2681a3814ec2449c964d9d0281dc0480180d32 SHA512 fdedd2b79ac8134b7cb819f2f713e7466c4e6f635155799dac0b95b5d97fc2010190b1e64c035b6f375082dff4e65cdf6389e267d25690caa7596dbb381c83c0
+DIST botocore-1.20.47.tar.gz 7619450 BLAKE2B c54015bbc537de9a8400f294e3e866f755f462515a2cbde8c15aa80d6d096f02442a71841cb9f9eca931ad948840c94946bcddd58fd1b81ef08d2cba88d9c7c2 SHA512 6f937133e8c9b3978367b4eeeb6b3a752e1d87d528cfc6ee1de8807ad5be14020815c130da25232405a09371a06d329da8b36fb29a0d1ff4391ccfd109727c1a
diff --git a/dev-python/botocore/botocore-1.20.47.ebuild b/dev-python/botocore/botocore-1.20.47.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.47.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}