summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-14 04:37:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-14 05:39:11 +0100
commit3defb0b4fd4b9190eb609b2adf0616cca5b7af80 (patch)
treee1d9fe0c2b9c17d6e5f86eeb54d48a57bc249b9c /dev-python/botocore
parentnet-firewall/conntrack-tools: Stabilize 1.4.8-r1 ppc, #943494 (diff)
downloadgentoo-3defb0b4fd4b9190eb609b2adf0616cca5b7af80.tar.gz
gentoo-3defb0b4fd4b9190eb609b2adf0616cca5b7af80.tar.bz2
gentoo-3defb0b4fd4b9190eb609b2adf0616cca5b7af80.zip
dev-python/botocore: Bump to 1.35.60
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.60.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e1532b527ae1..f0678c7a26ca 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.35.54.gh.tar.gz 13569174 BLAKE2B 1f4cb326d27ef028e16b20838fe1f7b
DIST botocore-1.35.57.gh.tar.gz 13603794 BLAKE2B 23a4dc82e1d9667e75494c2fb651b883c7fbaf689679a1b40c3f277c33760fbaacd6843e6630876fe75597c6e6dc892726c609a97efcff0d46533460c379c43f SHA512 f20eccdcd0c027e3c1d6c631988c8913f3150b1b6da679fc18ea75824d0ef61b999ee9cad4f0d74edbb639cf52daf188fd7e256664e57fc89be09f33ed78d65e
DIST botocore-1.35.58.gh.tar.gz 13608279 BLAKE2B 6f67c155f7b87c827b07f3bceb29836f59cf38479911cff8c92970e25b82baf920d673c8766e61c5db05e5dcbf1f46acc3aff2ebe32498d4ec733ea0a02a1718 SHA512 5db5c1832936a95ee11b80e872ece61f034ad61eb5c0d307deea047bca8785e9ca211d2f38349b234d7c5aa13ba363f4908520fa211be16924d3552d1bed27a7
DIST botocore-1.35.59.gh.tar.gz 13619172 BLAKE2B 593bae8b31935cabd5ca44e48bc85d1638d03a34d58ac209f9f0aa51ddc55c72f88b383fe422a10e0045a84e287da0c417ee388acdc72ebf982665532657aee0 SHA512 ced4d9c149924f09c6cb3fb62f348225f7df4a07be383b5f523d7284fefd2de0e60f4c302a71eaf81d56051a31e78d962e75eda28afb6624db0b0bac7fef9140
+DIST botocore-1.35.60.gh.tar.gz 13625896 BLAKE2B 3e1337713f2a96430eaac399db7d6ad468e991ac1c777fff6761dfc377104833ddbe711b8384e08086862a60e5e558c2aae48bb87bd399b2dbd00cb032b696fc SHA512 4e05899948f5ece08f51c4eda2e124f743ee5e5fa82e849585bb8065850e08e190d3b04b720af4ca651165e9b209d2dfab597ca7118cc2a18ce4badf72688dc9
diff --git a/dev-python/botocore/botocore-1.35.60.ebuild b/dev-python/botocore/botocore-1.35.60.ebuild
new file mode 100644
index 000000000000..0f88c5cbe9f3
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.60.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}