summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-11 04:09:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-11 05:09:44 +0200
commit569a6a7c273e357e2c552a5f2d53c498069d27f6 (patch)
tree162a1b7b81203226ce0f8f0aa4948db0357b48bc /dev-python/botocore
parentdev-python/PyQtWebEngine: Remove old (diff)
downloadgentoo-569a6a7c273e357e2c552a5f2d53c498069d27f6.tar.gz
gentoo-569a6a7c273e357e2c552a5f2d53c498069d27f6.tar.bz2
gentoo-569a6a7c273e357e2c552a5f2d53c498069d27f6.zip
dev-python/botocore: Bump to 1.35.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.16.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7ca94ed2b4e1..8f5a1c18c9b4 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,4 +1,5 @@
DIST botocore-1.35.10.gh.tar.gz 13328544 BLAKE2B cecad54696210597a09f4316a88b8335bc441a6429ddbc7f3c6e539a1aaee4312b855ec93b99971c8241b2431a920085f4f3b38545d607609a8d6a94d36676d8 SHA512 cf6bb103aea0af9ed2e43762848438eef89ab5bf8eec856cb8cd70204dd36f143ab9b8defd6ecd849a542332351feb499d8c34e7382bde558eac3ad19b1c5757
DIST botocore-1.35.14.gh.tar.gz 13340768 BLAKE2B 4ba023dbfc9e632d86028100910544e192a5b2d70ec76a21dfc5003c767a6043a144385561c35f4d7b4bfefbf4a1f3a38ef2845e323f93868e1f5ad86ae1f12b SHA512 c0dfdec80a45cf11796496bc2bef575a567368be3f29267b4d411d0615e6c8536036e47a5de11fb8f4626590dca051e891bb9430ed1ea80dfab2f43f070209d2
DIST botocore-1.35.15.gh.tar.gz 13343518 BLAKE2B 7eef64c875cc175aa94271b72a300908dc0f1c19504b0088acd5cf97224a4793bdc1bb5adc38e763359eb54892636feb2833726d217eb0a5f998c451e8de484e SHA512 305d16f4aad9832a6b405d2aa44805a89d70b57c74d0b4a25068801615cbdd9e6e223e804f1fd2c057ae3cc6515f0a20cab8adfda421e8c29ba911707fef0820
+DIST botocore-1.35.16.gh.tar.gz 13347546 BLAKE2B c6acfbab36b849ac0dcac177b4c6edf0acade33eac6c2215eea66df2d63307bdc9c130fee42f4e62385eb52fde6578d8a185a9be30dc3fde378242182636eb76 SHA512 e5c016a0107db1977f72497361f0b5f4755c4a8c25a9e715b556c17ac93af7a5d88c2a771814a80eda634b9b551d07da187f6d2a3107c53aed44fbcbe459a041
DIST botocore-1.35.5.gh.tar.gz 13303437 BLAKE2B 0a95351fbc93074bb0398871773120a194fe581a26f9a74c1101a5ea57bb3acb9a33937fc2d5a39a065988cdcc6dbe253bd2227cf93e670602ccc67ab82d8845 SHA512 5527420017a4a23d5593f5b3a0eb8caf15357642ed90cd73e0fe22774cc8f9f3637028286063e3e2810e5dafe52e882928269e5c82f6369be9af99bef18fb365
diff --git a/dev-python/botocore/botocore-1.35.16.ebuild b/dev-python/botocore/botocore-1.35.16.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.16.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}