summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-02 06:31:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-02 07:31:54 +0100
commit8020d87f2897a5308631fe1f20e1802a2600c002 (patch)
tree073ef18fc686da92226bd431e1cfe5d7c12b3df8 /dev-python/botocore
parentdev-python/pycpio: update rdep version (diff)
downloadgentoo-8020d87f2897a5308631fe1f20e1802a2600c002.tar.gz
gentoo-8020d87f2897a5308631fe1f20e1802a2600c002.tar.bz2
gentoo-8020d87f2897a5308631fe1f20e1802a2600c002.zip
dev-python/botocore: Bump to 1.35.54
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.54.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 37ee952f464c..97b873e7abeb 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.35.50.gh.tar.gz 13480380 BLAKE2B c75e98122762a9f061006019c3e8b12
DIST botocore-1.35.51.gh.tar.gz 13481192 BLAKE2B a1b5689178cf800baf69965a8b69ba317aeb0c8f4752973ea01c4f9ec4720aa1538dbbcf242a834374a7943597d012c2f1961b813a79648690fa06d6f3aee168 SHA512 40a00597ebf30548addef59a0e4c9c78fd7ffcbdff961a8ec15954d3b30b94fb5600c1cbb1e4e98a89c034958bf0ff55f71721cb8637a9a3439cb8cce188e132
DIST botocore-1.35.52.gh.tar.gz 13562020 BLAKE2B 3164243950d4f7cfee0d2b01c46ed9c61ac2db4361dd32caea263b4f424b3e35e7eef66c0e0885081b7ba81f3fdac3b7825b8cfd83d50e645489e9a05d2f20ee SHA512 ff2bd96033395f960c334574d3158832af35464119e4e66bb265964b34852fcb701b9dff8ce6c4337fa883926df949fc3236b946849c9815e7e9dcccfe9f14cc
DIST botocore-1.35.53.gh.tar.gz 13566810 BLAKE2B 6992501c08c89e56badf51658d07f1d2fa12662918a18b9bf65a9361dc370e4a1114b6327b30aacd3cc3bc9fde25aec4ea3e012c1263d47721fdf6d12f269405 SHA512 c3b6fbfc7ab724e085ac3e4df109ebd274c5375365de7e754c86726cdfdd4e5f331622ae9625ec4b22e8b526e09fc0e51541bdb371c1d1de2803b621e0b053b3
+DIST botocore-1.35.54.gh.tar.gz 13569174 BLAKE2B 1f4cb326d27ef028e16b20838fe1f7bc32cc5c782694d4d47dc2d0cd1384a7fdfe584f6225f41004c8e4c9028c1ac2b2b157daa073adab515d99a2cf1d42b19f SHA512 cab2956d9b7597295d761f232b9981085bb4daec182514fb514b6aed7bdb82ddca41b7b85900987f624828ae389f4ac282b0950692d965ccb9b67d6ce3d40362
diff --git a/dev-python/botocore/botocore-1.35.54.ebuild b/dev-python/botocore/botocore-1.35.54.ebuild
new file mode 100644
index 000000000000..0f88c5cbe9f3
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.54.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}