summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-22 06:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-22 07:01:52 +0200
commitab8fe267013d4ed27b0483ba4f28d30232a520fc (patch)
tree89e1b983f6dcc157296c089fc2b352b32c74d0c0 /dev-python/botocore
parentsci-biology/fasta: add 36.3.8i (diff)
downloadgentoo-ab8fe267013d4ed27b0483ba4f28d30232a520fc.tar.gz
gentoo-ab8fe267013d4ed27b0483ba4f28d30232a520fc.tar.bz2
gentoo-ab8fe267013d4ed27b0483ba4f28d30232a520fc.zip
dev-python/botocore: Bump to 1.35.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 71db3c651131..9277bc75c4ad 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.34.158.gh.tar.gz 13282704 BLAKE2B c244a36093cdaf57ac82dc11a3e9d4
DIST botocore-1.35.0.gh.tar.gz 13294975 BLAKE2B a0cbafd1b0da5cd7150ea7a2e21b1209b206b7afcb86ad3ff004ca1c96f47da34eff29a43568f0e9a2dca3443516fdb6adf7bd3778835b908fa5fb3a8d22f79a SHA512 7d0c9815703ef49a8958ed1a5159018320108ae86efe20e6dff182db24ceeb67968db7027ee75809a1ebd1c835709d0d758b0699742bca2e435888dbe5e15a97
DIST botocore-1.35.1.gh.tar.gz 13301129 BLAKE2B 70c99036e54331a63107c5c031cd32c59150ef2aa6fd9bf90bb4fe2a8d7eaed38d0a7df96c0ac1b973a14490e061e63e04dba873382cb2d69cbe2bf8b312a765 SHA512 92e4e6081bb7ee491acdc92356a2e661af02bb4b1a73d372dcdb1de913d89adfe0a1b3b16b1d4754e79601f051b4d2fab54d7512f3ca9d972b2256811cc704f0
DIST botocore-1.35.2.gh.tar.gz 13303549 BLAKE2B a93f708264e5d4332d4a63b11e57ea9575913e09cd5e2f0a23d050625e185f985c56bdc2652f2362bbdd037a74d2229c3998185cc96ba468bf2669f2dac4d773 SHA512 7f2309967c6c18445d122164d84951e7d602253388967dcf517e3b6bebe3a262eb0473181ce9145aefefefc2e9456aac05b321ec1b59fa08c162fced85a7dfe2
+DIST botocore-1.35.3.gh.tar.gz 13297160 BLAKE2B 930687ad4c327ab4aa964abf5b39729f766db5585e233d26635f02891c1e57f2c49ef3ee4029f4144757256f80038e196e02a5b98ebe4f344b78b8ecd38a52a1 SHA512 f65c211698d904db43605be3b979ab2c5a84219ae96cdd20ed0e044b9a6040cbb79a656c64c0396ba75cc5d7625255786596e629f4465088da0f5c143337199c
diff --git a/dev-python/botocore/botocore-1.35.3.ebuild b/dev-python/botocore/botocore-1.35.3.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}