summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-11 22:44:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-11 22:44:35 +0200
commitfe447788c46b112f2278f53c08f0d936360eb01c (patch)
tree86b84a441c0e5669a685aa6d2ee3bd50e5f326c1 /dev-python/botocore
parentdev-python/boto3: Remove old (diff)
downloadgentoo-fe447788c46b112f2278f53c08f0d936360eb01c.tar.gz
gentoo-fe447788c46b112f2278f53c08f0d936360eb01c.tar.bz2
gentoo-fe447788c46b112f2278f53c08f0d936360eb01c.zip
dev-python/botocore: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.104.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7757b52f3773..907197b1e53d 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,4 +1,3 @@
-DIST botocore-1.20.104.tar.gz 7883624 BLAKE2B 4fb4c6abff5a2c3d3e19b11576e723f15a442b2d49e461a2a4c2bd613e26095ceb87f4b7ceb672f338ea04ad918060bed118f7bc4c184c46cce1d6a9f98d4239 SHA512 2201d87ce2e1c8979548698d6a46eb03c0a2026360b178fea895ad6a244efad534d9970d3c6343d50639d25b3b8643db6744658fec14e0fa29fd7c4b45c8e0d8
DIST botocore-1.20.112.tar.gz 7917776 BLAKE2B 6a5ebf3d32c505ec2c1fc4cd3d97aa94c76b6206dda6ba28a946dfdc9973073019389c05d1cf09a0eced701fe86a9b8a292835415c0b1ceea75959a3186f65c6 SHA512 4b36367ffdd011aeb7654fd5c52c38e95bae4c55e5af85e38b0764140539ad1f8b9d75b0c7fd1009fda8d005ef4b17673b06f85a76b52fcebf05925297b6bbbf
DIST botocore-1.21.15.tar.gz 8012673 BLAKE2B cdd2b4128e67c85879e85f61265b10c1e5765eebf65333059af56a6a5b1d650a7612c4b569afde2396704015294e74b717c35d49c3e08396b2c603b7d47c632b SHA512 a5916ffa64568b2040d6f76571d9d716d50339fdaaed61f4ff7be92a5dac2c3f967280330fcbd3d6c2e1c1faf7bd6012ce75dd66ff26fde9d830d334a9d7c45a
DIST botocore-1.21.18.tar.gz 8034404 BLAKE2B f28cd392a0ca34bc5baa6316bcc9b040ab7cf429c6b16b1c9cb832d310640a75df21ac22634a565d91eeefcb1476f50487e2e80b52cfbfca1cdb9683e76d801f SHA512 485e3d293684659731061592082582678035ad657fe47cacd9f7608cf09d801bfd73951a3c0de77c65a79e6070638f0b3dddfa357d7f0ddbb773c70334b214b8
diff --git a/dev-python/botocore/botocore-1.20.104.ebuild b/dev-python/botocore/botocore-1.20.104.ebuild
deleted file mode 100644
index 6b848259897b..000000000000
--- a/dev-python/botocore/botocore-1.20.104.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="https://github.com/boto/botocore"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/botocore"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
-)
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
-
-src_prepare() {
- # unpin deps
- sed -i -e "s:>=.*':':" setup.py || die
- # very unstable
- sed -i -e 's:test_stress_test_token_bucket:_&:' \
- tests/functional/retries/test_bucket.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # note: suites need to be run separately as one of the unit tests
- # seems to be leaking mocks and breaking a few functional tests
- nosetests -v tests/unit ||
- die "unit tests failed under ${EPYTHON}"
- nosetests -v tests/functional ||
- die "functional tests failed under ${EPYTHON}"
-}