summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-17 00:59:18 +0100
committerSam James <sam@gentoo.org>2021-10-17 01:08:51 +0100
commit670728e3cc76e18fd20368db425bacb08c29ba40 (patch)
treeeaa18b598f48d1b329c4bfd2db7bb9699c7dfa39 /dev-python/cachelib
parentdev-util/bear: revbump for hlohmann_json dep adjustment (diff)
downloadgentoo-670728e3cc76e18fd20368db425bacb08c29ba40.tar.gz
gentoo-670728e3cc76e18fd20368db425bacb08c29ba40.tar.bz2
gentoo-670728e3cc76e18fd20368db425bacb08c29ba40.zip
dev-python/cachelib: skip fragile Redis tests
Involves spawning a daemon and that never seems to go well reliably. Closes: https://bugs.gentoo.org/818523 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/cachelib')
-rw-r--r--dev-python/cachelib/cachelib-0.3.0.ebuild6
-rw-r--r--dev-python/cachelib/cachelib-0.4.1.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/cachelib/cachelib-0.3.0.ebuild b/dev-python/cachelib/cachelib-0.3.0.ebuild
index 3ec6572206d0..3655d313ef2b 100644
--- a/dev-python/cachelib/cachelib-0.3.0.ebuild
+++ b/dev-python/cachelib/cachelib-0.3.0.ebuild
@@ -17,7 +17,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
BDEPEND="
test? (
- dev-db/redis
dev-python/pylibmc[${PYTHON_USEDEP}]
dev-python/pytest-xprocess[${PYTHON_USEDEP}]
dev-python/redis-py[${PYTHON_USEDEP}]
@@ -26,3 +25,8 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+)
diff --git a/dev-python/cachelib/cachelib-0.4.1.ebuild b/dev-python/cachelib/cachelib-0.4.1.ebuild
index 3ec6572206d0..3655d313ef2b 100644
--- a/dev-python/cachelib/cachelib-0.4.1.ebuild
+++ b/dev-python/cachelib/cachelib-0.4.1.ebuild
@@ -17,7 +17,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
BDEPEND="
test? (
- dev-db/redis
dev-python/pylibmc[${PYTHON_USEDEP}]
dev-python/pytest-xprocess[${PYTHON_USEDEP}]
dev-python/redis-py[${PYTHON_USEDEP}]
@@ -26,3 +25,8 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+)