summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-27 05:55:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-27 06:38:09 +0100
commit61c86b05a84e982bcaf45d4e4a970a068f3fc248 (patch)
treefae385eace5b70c7d13f321add585bdf153b728c /dev-python/caldav
parentsys-apps/portage: add 3.0.45.1, drop 3.0.45 (diff)
downloadgentoo-61c86b05a84e982bcaf45d4e4a970a068f3fc248.tar.gz
gentoo-61c86b05a84e982bcaf45d4e4a970a068f3fc248.tar.bz2
gentoo-61c86b05a84e982bcaf45d4e4a970a068f3fc248.zip
dev-python/caldav: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/caldav')
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-1.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index 3db6ef8cb3f6..9906099637a5 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1,3 +1,4 @@
DIST caldav-1.0.1.gh.tar.gz 133071 BLAKE2B d7b9eb8015782bed5d32b7c34508cfcc1334d33cdfed99003cf45893b0a894d5a3187a2c98f886f97ffe8a64140a5a3826e1b3f57b58228a61d1ad4f9bf9f72a SHA512 ac816afd74f6fe34d82345a8b3a934fbe2c37af6a75cc8ef91cd87c8b8d147962ff05e701cd91480c1963d57967898129f923655d366820b689959b00f55659f
DIST caldav-1.1.1.gh.tar.gz 136513 BLAKE2B a825b19023cadfd2b59e747c5d1b00065530d6773435a9f363d54cea7621f56eb6207b7a2888994fe5c42b873d6b82ba285abbc2ee5d18f72aafd90271cc5e87 SHA512 a1d991d468f093e6d54262f657e6e43ea9bf9e55dbe1f2fcb7189fb1e6a742805faee2a99807838f5db3406c1a9cd72a14054a30efe13e8d5ad7f113aaa88e2a
DIST caldav-1.1.3.gh.tar.gz 136529 BLAKE2B 275c56d74a5118697672deae9611054ef08638ebd476d0108286cb116dc1b102ed5ae36dcb85ebcc21eb36d02aeb02d47e5acdda510c568f8dd9ae85895518c8 SHA512 ec281ac41d14938a5c10a08ef8134a16987e14218e2a1b092a6c10d09b619fc8372d3be3c1fb139bdb2c1f183af0832d486f70554e4007a0dc145173fc4564fb
+DIST caldav-1.2.0.gh.tar.gz 122290 BLAKE2B 62e60695737298dae299aed6e73ed3570c51f5fd05d15f25fb34852e2ca97d6a3e700148f69b5a67f1fad0db8233426d0908f58d513602e8be171ebbb5fef1bb SHA512 56b329d1fcc9ef750e30721485825e067706280b48131816357df023b53e6631b6749e154d0db4815328588359cc98e996c35a0e93395f1cd58d4c36615f96e6
diff --git a/dev-python/caldav/caldav-1.2.0.ebuild b/dev-python/caldav/caldav-1.2.0.ebuild
new file mode 100644
index 000000000000..1a6a3ab32f5f
--- /dev/null
+++ b/dev-python/caldav/caldav-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/recurring-ical-events[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest