summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-13 05:35:20 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-13 05:38:11 +0100
commit67e14010a3c35ec4026b04f6445d970e7f72a299 (patch)
treecee6897a5a93e7968971b8ebb3c1cfc06e6f3a21 /dev-python/caldav
parentdev-python/google-auth-httplib2: Bump to 0.2.0 (diff)
downloadgentoo-67e14010a3c35ec4026b04f6445d970e7f72a299.tar.gz
gentoo-67e14010a3c35ec4026b04f6445d970e7f72a299.tar.bz2
gentoo-67e14010a3c35ec4026b04f6445d970e7f72a299.zip
dev-python/caldav: Bump to 1.3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/caldav')
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-1.3.9.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index 86a156600d23..e180b1d4b798 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1 +1,2 @@
DIST caldav-1.3.6.tar.gz 104671 BLAKE2B 9792074a91f54d9a300676b4a63ab3fc55650f94038863ebe9045b160f0936192cc597a9d3049d08e42023fe37498ab4fb7850680133ccd2f9ee5fb471fde690 SHA512 16b8b3c89efb97dc1629da075e3573cc87c7bbf5e7800008a02c0db339bdd5cdd72f3e939dd2581983cb6a6c5f1eb9d5715ef3c687cb73ff1777fdb778a51c81
+DIST caldav-1.3.9.tar.gz 106392 BLAKE2B 6b7ca6b7be72b604f54663c5d2a79bc0a3b9874c791407fb7161357bad4cc5016249d0dd8278fb394ff3ce9bfa681f8e034710706faf2d1b4eb8345ac3ba110c SHA512 d368511b82d341406801ecca6aa371a2b4f5641eedba784fa869d76ebd1836991fb2d1cdc12d42feb1a55db73dfb5d80da7efebf95759fd7b6e122129a001ae3
diff --git a/dev-python/caldav/caldav-1.3.9.ebuild b/dev-python/caldav/caldav-1.3.9.ebuild
new file mode 100644
index 000000000000..badd5aa55a31
--- /dev/null
+++ b/dev-python/caldav/caldav-1.3.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/recurring-ical-events-2.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest