summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-10 06:32:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-10 07:03:22 +0200
commit4c383da9b0a31488a5de8d40cb0c0df486a45e40 (patch)
tree5da9315b1c530e77d903241f36688e31c5667a8f /dev-python/cbor2
parentdev-python/hcloud: Bump to 2.3.0 (diff)
downloadgentoo-4c383da9b0a31488a5de8d40cb0c0df486a45e40.tar.gz
gentoo-4c383da9b0a31488a5de8d40cb0c0df486a45e40.tar.bz2
gentoo-4c383da9b0a31488a5de8d40cb0c0df486a45e40.zip
dev-python/cbor2: Bump to 5.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cbor2')
-rw-r--r--dev-python/cbor2/Manifest1
-rw-r--r--dev-python/cbor2/cbor2-5.6.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/cbor2/Manifest b/dev-python/cbor2/Manifest
index 016c6e760bbd..8391c43e3aa9 100644
--- a/dev-python/cbor2/Manifest
+++ b/dev-python/cbor2/Manifest
@@ -1 +1,2 @@
DIST cbor2-5.6.4.tar.gz 100865 BLAKE2B e15227a5ff802f41c488fc410ee495a7b1b986cdca42f84926b525ec9d7110aae851f0da8278d630360462793a15733662b19663aa04acc470b7a6b0ad1c2f4e SHA512 794a7b646d7672c8cae9b2fe14e817812dc2afef46664f9be810258fcd1cab132dd28f3d05a036bd188aa510ebf44972f8f175b9acb6eec7339aebe608544b2c
+DIST cbor2-5.6.5.tar.gz 100886 BLAKE2B cb929f7d5389e572008d0c494f3ca13c6c62638366286a64ef8432a683b58f8e92805cd1c68543ae14d9f8ce178542efae2884237d5d00ac12a86ffb598df5d6 SHA512 9c3fc14b579e8c687b3e955452fcf9056fcfcce8ebe72b89c7d6e74e0ba5a29e0a61a225bbb6040f73285dfcc9f3bb37758badbbf45bd723ead8ecdf7e64b685
diff --git a/dev-python/cbor2/cbor2-5.6.5.ebuild b/dev-python/cbor2/cbor2-5.6.5.ebuild
new file mode 100644
index 000000000000..e32385b8d4c2
--- /dev/null
+++ b/dev-python/cbor2/cbor2-5.6.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="
+ https://github.com/agronholm/cbor2/
+ https://pypi.org/project/cbor2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ >=dev-python/setuptools-61[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e "s/--cov//" pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x CBOR2_BUILD_C_EXTENSION=1
+ # pypy3 not supported upstream
+ if [[ ${EPYTHON} == pypy3 ]] || ! use native-extensions; then
+ CBOR2_BUILD_C_EXTENSION=0
+ fi
+ distutils-r1_python_compile
+}