summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-19 07:36:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-19 08:03:50 +0200
commit3400117565275519a2a8bd5e72b26f2ef411b971 (patch)
treed273f91497039d6696fa3d1143d0026deb6df01e /dev-python/cfn-lint
parentdev-python/pudb: Bump to 2024.1.3 (diff)
downloadgentoo-3400117565275519a2a8bd5e72b26f2ef411b971.tar.gz
gentoo-3400117565275519a2a8bd5e72b26f2ef411b971.tar.bz2
gentoo-3400117565275519a2a8bd5e72b26f2ef411b971.zip
dev-python/cfn-lint: Bump to 1.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.17.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index e2e736681d78..f6fa4ce00fe7 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn_lint-1.15.2.tar.gz 2444882 BLAKE2B bb1e47da23087a667cfc3a1a36af962ad0db
DIST cfn_lint-1.16.1.tar.gz 2328621 BLAKE2B 034738d924ac720a1e85569d65afd47c4cf0cf81b8187f03de48e968872b0c993d40a56b7a6b5c751e252461ebe29b750cdc6405ebc4733020bcc28f8c6887be SHA512 4348ef8b9cc125c71b62ced41ecc16d6aaba7c194a95e28bc99a1cc49e4a931f1e6726286a9f31fd7f0a4692861e62efb9cde4482762f230aea963866aa8081a
DIST cfn_lint-1.17.0.tar.gz 2526551 BLAKE2B d1e57328317625cd31594662071c6a2c065ef74a8d836b4be1560f1023c9efb758add82f07ddfa60fc4be508a0efc7eef3850433ae05116bfa5d1efd6e9a0076 SHA512 cb3bc0f2ef38a7ea652c9cd94fae9ccf940924131fe03c49e5a58d28174ea4b900b90d342ef1c7f8287b9ce1c1889086b6c5ffbed12a40b4fb01861193ba6862
DIST cfn_lint-1.17.1.tar.gz 2526513 BLAKE2B fd59bd81e51e000c5360298b1e865b90dd7b517c349fab660078d13b84bca3cc688bcea021463a257a4fd81d9abebe51d08b863a5d915c4e16e7b457dfb0ca44 SHA512 745034c521f064fc2ec53bc6ccc8f992847987721d2b3f52f0c646e8ee9369563d27f331d9fcc10f8427b515b5277cde1c6917641df2c610190ede296cfa3a28
+DIST cfn_lint-1.17.2.tar.gz 2526962 BLAKE2B 76feefa1bcce6a0957ce028d6041ac49b475cf25bd843e7de30b1d05d797e55d4189d9deba087f569f94f2f8fc40b11c3ecddcab1593432abf0da1bd26db6da9 SHA512 79fa133244cfe1239648209da9e8bbb2e50435bc5c18b6f998c90eb09536a760dfae62507123c22295098bf0866b1ef0ed05853debb00e651b75651921401530
diff --git a/dev-python/cfn-lint/cfn-lint-1.17.2.ebuild b/dev-python/cfn-lint/cfn-lint-1.17.2.ebuild
new file mode 100644
index 000000000000..086f03ea08df
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.17.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.91.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}