summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 16:22:01 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 18:12:02 +0300
commit0c0de4f445c06c998c4ffbb565425fc702d3a3ec (patch)
treebdaae8b94736bee90008848c271e20ee47e63a0f /dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild
parentdev-python/rnc2rng: Add py3.7 (diff)
downloadgentoo-0c0de4f445c06c998c4ffbb565425fc702d3a3ec.tar.gz
gentoo-0c0de4f445c06c998c4ffbb565425fc702d3a3ec.tar.bz2
gentoo-0c0de4f445c06c998c4ffbb565425fc702d3a3ec.zip
dev-python/citeproc-py: Add py3.7 and move to eapi7
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild')
-rw-r--r--dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild b/dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..b81b9c57d500
--- /dev/null
+++ b/dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Yet another Python CSL Processor"
+HOMEPAGE="https://pypi.python.org/pypi/citeproc-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/b1a5f925527093b0b5c11507f379a908e3354820.patch" )
+
+RDEPEND="
+ dev-python/rnc2rng[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}"