summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-10 05:08:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-10 05:13:20 +0200
commit604b5f62896c1feec887f6ff710e2877520c63dd (patch)
treef0f749c179259db63c2b4e13647ad2f7e2e1e486 /dev-python/cliff
parentdev-python/PyGithub: Bump to 1.58.2 (diff)
downloadgentoo-604b5f62896c1feec887f6ff710e2877520c63dd.tar.gz
gentoo-604b5f62896c1feec887f6ff710e2877520c63dd.tar.bz2
gentoo-604b5f62896c1feec887f6ff710e2877520c63dd.zip
dev-python/cliff: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-4.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index c628a42d7fc8..6e128e47a28c 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-4.2.0.tar.gz 83168 BLAKE2B ac2d288ac3728f4266d61edb9b6aedc897e9020d3f8a74ebba4721530942a27335564c2a95406a4d6b5374df49e38bc0aa303d3aff12f83c91e48c59f13aa45f SHA512 6f0c31b49603be5289e6d4c9b2572862e977264df21dc14d976289c627909102d672ee8ffa5b6cd79b3a349158ff8f36444a2d2061e18eeb7121ce79b2d5719b
+DIST cliff-4.3.0.tar.gz 82652 BLAKE2B 8d4977e3541fd9de21fb637069abcb92cf38b07f47f0d61d329397ab9d42335f18faa6d7d13862b7f188632af39d46118d0f3ebfcf2475b67c258388aa4bbcc2 SHA512 b4ed6fcec05017c999d54188459aa93c9a35660b0ceb505525f22a6bb7632e3548e91d8dc00db381c314a3818be2a457b7aee3307da35915ea7519c1e13091a3
diff --git a/dev-python/cliff/cliff-4.3.0.ebuild b/dev-python/cliff/cliff-4.3.0.ebuild
new file mode 100644
index 000000000000..3969d97bb918
--- /dev/null
+++ b/dev-python/cliff/cliff-4.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest