summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-09 19:25:08 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-09 19:43:19 +0100
commit3adc8d88a397097dcef967ed6b7254c91f74b3af (patch)
treeab38956dc185bb92f508e83a9742455e0baf0c4c /dev-python/colour
parentdev-python/netaddr: Add dev-python/furo doc-dep (diff)
downloadgentoo-3adc8d88a397097dcef967ed6b7254c91f74b3af.tar.gz
gentoo-3adc8d88a397097dcef967ed6b7254c91f74b3af.tar.bz2
gentoo-3adc8d88a397097dcef967ed6b7254c91f74b3af.zip
dev-python/colour: Rewrite the build system to fix .dist-info
Closes: https://bugs.gentoo.org/921644 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/colour')
-rw-r--r--dev-python/colour/colour-0.1.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/colour/colour-0.1.5-r1.ebuild b/dev-python/colour/colour-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..b4e991316597
--- /dev/null
+++ b/dev-python/colour/colour-0.1.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python color representations manipulation library"
+HOMEPAGE="
+ https://github.com/vaab/colour/
+ https://pypi.org/project/colour/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # Upstream uses dead & broken d2to1, just make a quick flit config
+ # to make it work.
+ cat > pyproject.toml <<-EOF
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "colour"
+ version = "${PV}"
+ description = "${DESCRIPTION}"
+ EOF
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --doctest-modules
+}