summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-11 20:02:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-11 20:39:22 +0200
commit4bfbc7c699ae0ca13529fc93214c99f23cb1c11d (patch)
tree07ae4e92e2d486c239e8ae2f5ee048033ee24012 /dev-python/configshell-fb
parentdev-python/scikit-learn: Bump to 1.5.2 (diff)
downloadgentoo-4bfbc7c699ae0ca13529fc93214c99f23cb1c11d.tar.gz
gentoo-4bfbc7c699ae0ca13529fc93214c99f23cb1c11d.tar.bz2
gentoo-4bfbc7c699ae0ca13529fc93214c99f23cb1c11d.zip
dev-python/configshell-fb: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configshell-fb')
-rw-r--r--dev-python/configshell-fb/Manifest1
-rw-r--r--dev-python/configshell-fb/configshell-fb-2.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 4b2c0a5102ae..884a0b6777aa 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1,2 @@
DIST configshell-fb-1.1.30.gh.tar.gz 33179 BLAKE2B 8664ec42727fb9bd41600c2844b9b59423c21040e6efc201f40b54abf6d788fa5237d38e2795d0d19706303d99e7ea859b399fd5f122cb04effc643a33b264ac SHA512 b3189130ac047fe28ea987391591b7886f7234864d455a8423d1d65b02a514511e2a32dce1429a6b71cedbc0b7cb6e6e10f29d240b746d222c285f0baa6b46b0
+DIST configshell_fb-2.0.0.tar.gz 33794 BLAKE2B 7bb46a19b58107c7e4d0f7a4dde9520cdd31b85238ad7579f85c30f855c7fb90736470419e7f6882bbeed89d9d55091b92f7a3f1e4bbff5e5a9eae813c148756 SHA512 3e0c0c3fda661cd09d80cd07e32cc942aa804fde49c00cfed5234671b1005f8126264c39a72aec466b3b9324366faa83828eee74f8b541d6f8bc628548d31a9e
diff --git a/dev-python/configshell-fb/configshell-fb-2.0.0.ebuild b/dev-python/configshell-fb/configshell-fb-2.0.0.ebuild
new file mode 100644
index 000000000000..dc77fba66ca9
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="
+ https://github.com/open-iscsi/configshell-fb/
+ https://pypi.org/project/configshell-fb/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
+}