summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 05:51:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 05:51:53 +0200
commit3c8257fba3c2b0ecd2808251d41769d1f0386345 (patch)
treed4534711f0b0fb75cc941271456bd3bb7ab045ec /dev-python/crispy-bootstrap4
parentdev-python/django-crispy-forms: Enable py3.12 (diff)
downloadgentoo-3c8257fba3c2b0ecd2808251d41769d1f0386345.tar.gz
gentoo-3c8257fba3c2b0ecd2808251d41769d1f0386345.tar.bz2
gentoo-3c8257fba3c2b0ecd2808251d41769d1f0386345.zip
dev-python/crispy-bootstrap4: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crispy-bootstrap4')
-rw-r--r--dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild
index 1603b39db3f0..98602ed39570 100644
--- a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild
+++ b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2022.1.ebuild
@@ -4,26 +4,35 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Bootstrap4 template pack for django-crispy-forms"
HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/
https://pypi.org/project/crispy-bootstrap4/
"
-SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RDEPEND="dev-python/django-crispy-forms[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- dev-python/pytest-django[${PYTHON_USEDEP}]
-)"
+RDEPEND="
+ dev-python/django-crispy-forms[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
-PATCHES=( "${FILESDIR}"/${P}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+)