summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-04-09 14:41:24 +0300
committerMichał Górny <mgorny@gentoo.org>2017-04-12 23:06:04 +0200
commit3a1188b5e0769701d888cf9c49b688824f9e1fa0 (patch)
tree78eb221f0baa01cb9224c61959126df681ddf64b /dev-python/cssutils/cssutils-1.0.1.ebuild
parentsys-kernel/vanilla-sources: Version bump to 4.10.10 (diff)
downloadgentoo-3a1188b5e0769701d888cf9c49b688824f9e1fa0.tar.gz
gentoo-3a1188b5e0769701d888cf9c49b688824f9e1fa0.tar.bz2
gentoo-3a1188b5e0769701d888cf9c49b688824f9e1fa0.zip
dev-python/cssutils: python 3.6 support
add missing depend on dev-python/nose for tests
Diffstat (limited to 'dev-python/cssutils/cssutils-1.0.1.ebuild')
-rw-r--r--dev-python/cssutils/cssutils-1.0.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.1.ebuild b/dev-python/cssutils/cssutils-1.0.1.ebuild
index ca60f9ed139a..dc4289b6fe2b 100644
--- a/dev-python/cssutils/cssutils-1.0.1.ebuild
+++ b/dev-python/cssutils/cssutils-1.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
inherit distutils-r1
@@ -17,7 +17,10 @@ IUSE="test"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
PATCHES=(
"${FILESDIR}"/${P}-pypy-test-backport.patch