summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:01:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:01:25 +0300
commitf1140aa09580b6f12649d3ceeaf215bdd350a5e5 (patch)
tree46387d587275300b8efe0a7644db9b215e5031b7 /dev-python/cx_Freeze
parentmedia-libs/ilmbase: Stabilize 2.5.8 hppa, #853670 (diff)
downloadgentoo-f1140aa09580b6f12649d3ceeaf215bdd350a5e5.tar.gz
gentoo-f1140aa09580b6f12649d3ceeaf215bdd350a5e5.tar.bz2
gentoo-f1140aa09580b6f12649d3ceeaf215bdd350a5e5.zip
dev-python/cx_Freeze: add 6.11.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cx_Freeze')
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.11.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index c87659fe2306..52668f1791eb 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -1,2 +1,3 @@
DIST cx_Freeze-6.11.0.gh.tar.gz 1307157 BLAKE2B 6897dcec37f606cf5440e8bc849dfc5c20f4cbd79099da973f855d99d8cc59845da526c36d3918dc85e5c2b279b089468c07cd7f3849b452f109205d9d4e4fc3 SHA512 f10556c9ca1222fcc4fc4a31588a57788067dc16c5ac365503e95e2df0729ae045b7b1ac6416736e9193759a054545e3966dac54136991094183dd0b93b2f47a
+DIST cx_Freeze-6.11.1.gh.tar.gz 1307368 BLAKE2B 7bfbe61274b29890ba35fda133d4c18708d3a04bc33c96633f6651fb9712fec4628f92e2044284ad1bfb992a76e4772669a29ada2f12f16741378d636701e4ad SHA512 37586365a901800fcd18ab6e3b0de9e3e9980c8d8b8b61aa1eddf0d01dc50b53cb1ffc77070f5a5ad40c9b7a020b09ced51d38f53688129b2444abe020a75237
DIST cx_Freeze-6.9.gh.tar.gz 1273371 BLAKE2B d005fdf0e2ac49cb4f347256d3b643124694a0628e4abf6806c122c144bb973e14a2d9101b2d446394d50c6c0d9af7edca1e62b50bb4d76f63c96fabfda6cc7c SHA512 219f052cae05a757c2cd57c45e47c0b3e85662ace895a8b768e1571044e132b7db367af2a6293d175e022f79f87b02007dfdd8807eb39be04a89602b51cc0246
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.11.1.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.11.1.ebuild
new file mode 100644
index 000000000000..11a6209600a1
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.11.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="https://cx-freeze.readthedocs.io/"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ virtual/libcrypt:=
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # new setuptools?
+ tests/test_bdist_rpm.py::test_bdist_rpm
+)