summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-08 19:23:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-08 19:44:29 +0200
commitabc8e7b1a17232bef6140274e2b389d29698fb68 (patch)
tree953b576432e82ea590661e9379bfb5da64a8040a /dev-python/dill
parentdev-python/dill: Hack numpy support out because of breakage with np2 (diff)
downloadgentoo-abc8e7b1a17232bef6140274e2b389d29698fb68.tar.gz
gentoo-abc8e7b1a17232bef6140274e2b389d29698fb68.tar.bz2
gentoo-abc8e7b1a17232bef6140274e2b389d29698fb68.zip
dev-python/dill: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/dill-0.3.8-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/dill/dill-0.3.8-r2.ebuild b/dev-python/dill/dill-0.3.8-r2.ebuild
index 5699bed923d1..94ced8edf7b9 100644
--- a/dev-python/dill/dill-0.3.8-r2.ebuild
+++ b/dev-python/dill/dill-0.3.8-r2.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-# py3.13: https://github.com/uqfoundation/dill/issues/654
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -27,5 +26,8 @@ src_prepare() {
}
python_test() {
+ # disables a test broken under Python 3.13
+ # https://github.com/uqfoundation/dill/issues/668
+ local -x COVERAGE=1
"${EPYTHON}" -m dill.tests || die
}