summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 20:53:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 21:05:38 +0100
commit9e9bd91c51efd671ad7ab7728db59c2ed4a1c000 (patch)
tree3f3a02df82fb336660103f5f3b5f2416b3938f7a /dev-python/dirty-equals
parentdev-python/fonttools: Bump to 4.44.1 (diff)
downloadgentoo-9e9bd91c51efd671ad7ab7728db59c2ed4a1c000.tar.gz
gentoo-9e9bd91c51efd671ad7ab7728db59c2ed4a1c000.tar.bz2
gentoo-9e9bd91c51efd671ad7ab7728db59c2ed4a1c000.zip
dev-python/dirty-equals: Bump to 0.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest1
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.7.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index 1f897fcaf030..ae0e06993e5a 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1 +1,2 @@
DIST dirty-equals-0.6.0.gh.tar.gz 47114 BLAKE2B 910f09e5f5b2ec62d3b4d50ac23a17ee481875b9ae7303faf9bb610282113941b8a121d39e14e1a63cae0433055e639b1bc2da5c1fc3a9ece4915e34c172f40b SHA512 aff41b31c255294c2d6c3a3170daea56d98da4875f9ffdef96b522db24fbed92edf4618646b3e1b50680ce03fca1b9c2bb591730c397b85143ace846c513ac01
+DIST dirty-equals-0.7.1.gh.tar.gz 49000 BLAKE2B 06c9a7522f1dda95ff682dc9c28207b29754d11b4afe7eeacd5439a9ae9f34ce0a2f5724703129aa90b5577f36646deafa5428120e823502aae616d57b3d8f0d SHA512 c50a15e4cee77b3db1b07ef9f7d1eb5b3ab6bed6d914ac5c9e2982f8cf9432beaecb5fd7997d46a94f405e0c932ea5a8d72f1c1d4b6dda86161c22cc772ab4d7
diff --git a/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild b/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild
new file mode 100644
index 000000000000..e072dbd547a1
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require unpackaged pytest-examples
+ tests/test_docs.py
+ )
+
+ local -x TZ=UTC
+ epytest "${args[@]}"
+}