summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-16 15:15:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-16 15:17:32 +0200
commit89d0abfcf710cb290de3172108914000ac547b01 (patch)
treea8e0c96141632c34f53d97a092683989040c8eb5 /dev-python/django-allauth
parentdev-python/discogs-client: Remove old (diff)
downloadgentoo-89d0abfcf710cb290de3172108914000ac547b01.tar.gz
gentoo-89d0abfcf710cb290de3172108914000ac547b01.tar.bz2
gentoo-89d0abfcf710cb290de3172108914000ac547b01.zip
dev-python/django-allauth: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-allauth')
-rw-r--r--dev-python/django-allauth/Manifest1
-rw-r--r--dev-python/django-allauth/django-allauth-0.49.0.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/django-allauth/Manifest b/dev-python/django-allauth/Manifest
index 0e4fc5071894..6fec23db50ca 100644
--- a/dev-python/django-allauth/Manifest
+++ b/dev-python/django-allauth/Manifest
@@ -1,2 +1 @@
-DIST django-allauth-0.49.0.tar.gz 702336 BLAKE2B 0f39ff98e8e6d18b80e2ce858dcc104a0bf41eded6d1211f157c158030a65494bfbdc522d37242247d260413d75bd73f4d50bc53e9993d3bd6517b062faccee8 SHA512 134c578c65c61da393cbdb2a2f3ea3fdc32479371af0106af8f97eb794315c3025a705fb659a81b11618924dc2968c57dbcf1fdc03cec023de14deb94307d8de
DIST django-allauth-0.50.0.tar.gz 703083 BLAKE2B cb43eb09c5385020a581ecdc97acb74329d9c188f4365d91a46b8d2fe742d1d497bdd08d39cff36c93958e885fa1098a2b15218b296f1d9bf9211320aed247b6 SHA512 bf769e639ad37cfa150ed115b88d8802ae2f407461738a0dd2f39b055a4afc1468fe30d47a86e8f22697d2e67d4277078218c76f6c394a5cc685b7b21fa0a53a
diff --git a/dev-python/django-allauth/django-allauth-0.49.0.ebuild b/dev-python/django-allauth/django-allauth-0.49.0.ebuild
deleted file mode 100644
index e44b2c123562..000000000000
--- a/dev-python/django-allauth/django-allauth-0.49.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Django 3rd party (social) account authentication"
-HOMEPAGE="
- https://www.intenct.nl/projects/django-allauth/
- https://github.com/pennersr/django-allauth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/pyjwt[${PYTHON_USEDEP}]
- dev-python/python3-openid[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]"
-# cryptography via pyjwt[crypto]
-RDEPEND+="
- dev-python/cryptography[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( ${RDEPEND} )"
-
-DOCS=( README.rst AUTHORS ChangeLog.rst )
-
-src_test() {
- # cern provider tests require Internet
- rm allauth/socialaccount/providers/cern/tests.py || die
- distutils-r1_src_test
-}
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=test_settings
- local -x PYTHONPATH=.
- django-admin test -v 2 || die "Tests failed with ${EPYTHON}"
-}