summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-16 10:04:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-16 10:04:45 +0200
commit0fba729bc24c2cef24277fd1314d40a8143356a8 (patch)
tree46bc33d723cd0c2c96c5418f11d70ab864e73277 /dev-python/django-cacheops
parentdev-python/discogs-client: Remove old (diff)
downloadgentoo-0fba729bc24c2cef24277fd1314d40a8143356a8.tar.gz
gentoo-0fba729bc24c2cef24277fd1314d40a8143356a8.tar.bz2
gentoo-0fba729bc24c2cef24277fd1314d40a8143356a8.zip
dev-python/django-cacheops: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cacheops')
-rw-r--r--dev-python/django-cacheops/Manifest1
-rw-r--r--dev-python/django-cacheops/django-cacheops-6.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/django-cacheops/Manifest b/dev-python/django-cacheops/Manifest
index f0d6fb486eba..3deefef610a6 100644
--- a/dev-python/django-cacheops/Manifest
+++ b/dev-python/django-cacheops/Manifest
@@ -1,2 +1 @@
-DIST django-cacheops-6.0.tar.gz 70280 BLAKE2B 9efe5a10d86f9ad25ad67701005de962185d2c491305bb56920203718c2d5fd0b28d43f2463e28c7c00c7592a78a3adea66090b398a205d5e361dfbcf90ae887 SHA512 54ecec62ff255a867b382bb1157117c8d14d7185891aacaae33ea11283beeae2fae60659621699a52f86d536b5a582d31f24f3b00f16c2e81c1a78ea4079504e
DIST django-cacheops-6.1.gh.tar.gz 52972 BLAKE2B bdcd045912100ebdfdfd9add23b0df634b029cc2ffe41c351176e327f1e21c90457cfca9e45348dddce60e39fee5c431428ff7f2c954194e4c06c8bc09d78945 SHA512 43dcd4f302afee1acf73125aae7c2e2eece560cc6f07f3374391ac54e0438fd59b80a24e65f52bd7aa4978fd8a428939a8d607c7aa4b25f47d68373cfc12772f
diff --git a/dev-python/django-cacheops/django-cacheops-6.0.ebuild b/dev-python/django-cacheops/django-cacheops-6.0.ebuild
deleted file mode 100644
index ecfd5010beb1..000000000000
--- a/dev-python/django-cacheops/django-cacheops-6.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="ORM cache with automatic granular event-driven invalidation for Django"
-HOMEPAGE="https://github.com/Suor/django-cacheops"
-SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-1.8[${PYTHON_USEDEP}]
- >=dev-python/redis-py-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/funcy-1.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-db/redis
- dev-python/dill[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- # Remove test dependent on unpackaged before_after
- sed -e 's/test_lock/_&/' -i tests/test_extras.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings
- django-admin test -v 2 || die
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}