summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-14 16:48:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-14 16:57:52 +0200
commit0281bf087de15859461bea835c62c44b5b6d78f2 (patch)
tree5b00b7cc84ee0c09c9360c075d4e5fbe853ae85f /dev-python/django-taggit/django-taggit-5.0.1.ebuild
parentdev-python/dbus-next: Enable py3.12 (diff)
downloadgentoo-0281bf087de15859461bea835c62c44b5b6d78f2.tar.gz
gentoo-0281bf087de15859461bea835c62c44b5b6d78f2.tar.bz2
gentoo-0281bf087de15859461bea835c62c44b5b6d78f2.zip
dev-python/django-taggit: Bump to 5.0.1
Closes: https://bugs.gentoo.org/906702 Closes: https://bugs.gentoo.org/929451 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-taggit/django-taggit-5.0.1.ebuild')
-rw-r--r--dev-python/django-taggit/django-taggit-5.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/django-taggit/django-taggit-5.0.1.ebuild b/dev-python/django-taggit/django-taggit-5.0.1.ebuild
new file mode 100644
index 000000000000..f4709002e528
--- /dev/null
+++ b/dev-python/django-taggit/django-taggit-5.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple tagging for Django"
+HOMEPAGE="
+ https://github.com/jazzband/django-taggit/
+ https://pypi.org/project/django-taggit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-4.1[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings=tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}