summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-26 00:19:19 -0400
committerSam James <sam@gentoo.org>2024-06-26 10:03:50 +0100
commit1e91fddc4027880e60dc29faf64fa6b83a875fc7 (patch)
treeef62ec19051cbaf883e80e19d2bb64a0b340e63d /dev-python/doc8
parentdev-python/doit: conditionalize tomli/tomlkit imports after stdlib tomllib (diff)
downloadgentoo-1e91fddc4027880e60dc29faf64fa6b83a875fc7.tar.gz
gentoo-1e91fddc4027880e60dc29faf64fa6b83a875fc7.tar.bz2
gentoo-1e91fddc4027880e60dc29faf64fa6b83a875fc7.zip
dev-python/doc8: fix overdependency on tomli
Since 1.0.0, it has supported using the stdlib tomllib when available: https://github.com/PyCQA/doc8/commit/a3638de1337484b26da99dc5ea4287341b9ad9f6 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/doc8')
-rw-r--r--dev-python/doc8/doc8-1.1.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/doc8/doc8-1.1.1-r1.ebuild b/dev-python/doc8/doc8-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..5cab3caa8c81
--- /dev/null
+++ b/dev-python/doc8/doc8-1.1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/PyCQA/doc8/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/docutils-0.21[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# setuptools_scm_git_archive is not actually needed here
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest