summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-05-16 15:45:41 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-16 15:59:45 +0300
commit3861f4efcb5300df474085fe323b35db165a22be (patch)
treee78cfd4c711a19f0f01527ea9227f5c5459d845e /dev-python/doit
parentdev-python/doit: update ebuild (diff)
downloadgentoo-3861f4efcb5300df474085fe323b35db165a22be.tar.gz
gentoo-3861f4efcb5300df474085fe323b35db165a22be.tar.bz2
gentoo-3861f4efcb5300df474085fe323b35db165a22be.zip
dev-python/doit: use distutils_enable_sphinx
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/doit-0.32.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/doit/doit-0.32.0-r1.ebuild b/dev-python/doit/doit-0.32.0-r1.ebuild
index 210fb0296c51..e73b597bd0ed 100644
--- a/dev-python/doit/doit-0.32.0-r1.ebuild
+++ b/dev-python/doit/doit-0.32.0-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python3_{6,7} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -20,7 +21,6 @@ RDEPEND="
dev-python/pyinotify[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="
- doc? ( dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
@@ -30,7 +30,7 @@ DEPEND="
PDEPEND=">=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
-distutils_enable_sphinx doc
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
PATCHES=(
"${FILESDIR}/${P}_pytest5.4.patch"