summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/editobj
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/editobj')
-rw-r--r--dev-python/editobj/Manifest1
-rw-r--r--dev-python/editobj/editobj-0.5.7-r1.ebuild34
-rw-r--r--dev-python/editobj/editobj-0.5.7-r2.ebuild30
-rw-r--r--dev-python/editobj/metadata.xml10
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/editobj/Manifest b/dev-python/editobj/Manifest
new file mode 100644
index 000000000000..ca9b744eb9bf
--- /dev/null
+++ b/dev-python/editobj/Manifest
@@ -0,0 +1 @@
+DIST EditObj-0.5.7.tar.gz 39802 SHA256 9c72f7d9a9e31e9d7500b29583909246f5d3d7baf4b190f6be1dea4eb1da18ff SHA512 0b7603b00a09942d1ebd2b50203b698598b54a2334d5b69b638d5f4b0ff7273afeab5f4e0dbccc3eecc3349fc08dead1a6e056b858f419faecc7837a5af2df03 WHIRLPOOL 1af08ec076b693201919c5c17c1750bf0dc234a4b41c8c732535d2060c39ab99dc50c53fc80004d755cfbb9fa3ebb49822e38c0b60ec92b28b89b13263f88627
diff --git a/dev-python/editobj/editobj-0.5.7-r1.ebuild b/dev-python/editobj/editobj-0.5.7-r1.ebuild
new file mode 100644
index 000000000000..050b48d98d47
--- /dev/null
+++ b/dev-python/editobj/editobj-0.5.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit distutils
+
+MY_P="${P/editobj/EditObj}"
+
+DESCRIPTION="EditObj can create a dialog box to edit ANY Python object"
+SRC_URI="http://download.gna.org/songwrite/${MY_P}.tar.gz"
+HOMEPAGE="http://home.gna.org/oomadness/en/editobj/index.html"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ia64 ppc x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r demo
+}
diff --git a/dev-python/editobj/editobj-0.5.7-r2.ebuild b/dev-python/editobj/editobj-0.5.7-r2.ebuild
new file mode 100644
index 000000000000..4b1762e3b250
--- /dev/null
+++ b/dev-python/editobj/editobj-0.5.7-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/editobj/EditObj}"
+
+DESCRIPTION="EditObj can create a dialog box to edit ANY Python object"
+SRC_URI="http://download.gna.org/songwrite/${MY_P}.tar.gz"
+HOMEPAGE="http://home.gna.org/oomadness/en/editobj/index.html"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+SLOT="0"
+IUSE="+examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demo/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/editobj/metadata.xml b/dev-python/editobj/metadata.xml
new file mode 100644
index 000000000000..a0703461b6b8
--- /dev/null
+++ b/dev-python/editobj/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+EditObj can create a dialog box to edit ANY Python object. It also
+includes a Tk tree widget, an event and a multiple undo-redo
+frameworks.
+</longdescription>
+</pkgmetadata>