summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 21:48:40 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 22:06:06 +0200
commit3272e3f5ea1bc1bbde961b8725135e616f3b79dd (patch)
tree3640bdacb150bd9a20e8104e5137851b94d7b894 /dev-python/elementpath
parentdev-python/pytest-flake8: add 1.1.0 (diff)
downloadgentoo-3272e3f5ea1bc1bbde961b8725135e616f3b79dd.tar.gz
gentoo-3272e3f5ea1bc1bbde961b8725135e616f3b79dd.tar.bz2
gentoo-3272e3f5ea1bc1bbde961b8725135e616f3b79dd.zip
dev-python/elementpath: add 2.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.5.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 24a29e2e2b2d..5975eee0de22 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-2.4.0.gh.tar.gz 243871 BLAKE2B 1a16fa97a93a8a981c71d83a406353b5b002ea4fd814f177b7abff86ed0875770788737dc69843920cee1cc457b9a16859e6b1f4fd29889e3bf4d11b5b766621 SHA512 887a108b5de24a9be3dd1c577c623cf96939752f7c293d941e3b0bed4281d38a8edccf82fef9be8ee94bda7674f68ed17d3a060f803dcafce96e45961852ca24
+DIST elementpath-2.5.0.gh.tar.gz 263680 BLAKE2B 50ecea0766ddad4239b9283b223e945ae12fabf51bc246bb672517d04912b07cc2d46c1f04ff74f7f6da44d7dc422cde0c38a1f25a1f61068390dbfcc5ad58c4 SHA512 bbc6ce6a6a3eb3312d53be6040b8f4676f460e76de9b476410a3170734410b7a3d61c53081633d39089def05c74446d26abe093f02b9686a595cdb6e10440047
diff --git a/dev-python/elementpath/elementpath-2.5.0.ebuild b/dev-python/elementpath/elementpath-2.5.0.ebuild
new file mode 100644
index 000000000000..c29e78f2f38d
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest