summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-11 04:31:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-11 04:32:53 +0100
commit41fd309d44f5140728dfc4678ee7a0667fae7be4 (patch)
tree932f7bfbeb202435d3cc2d8a9db294b2499aece4 /dev-python/elementpath
parentdev-python/uvicorn: Bump to 0.27.1 (diff)
downloadgentoo-41fd309d44f5140728dfc4678ee7a0667fae7be4.tar.gz
gentoo-41fd309d44f5140728dfc4678ee7a0667fae7be4.tar.bz2
gentoo-41fd309d44f5140728dfc4678ee7a0667fae7be4.zip
dev-python/elementpath: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-4.2.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 3e95e089546a..5218f1924f6d 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-4.1.5.tar.gz 321891 BLAKE2B 70acff5974607a9ae79e90186f5477df8d85c5b42ff03625fbf006a02de82bbf14b79de3df55b38d65e9317fb5ab4ba4e27c38b8f7d8af11905340bb29e66731 SHA512 64a58dce8d7baf26286420ef15227804dd7f0296a8666929fbbb4425ee5523352dc8a0d610f6c7d1b9322a2292d6115ace79e0399f3c77cd074c85a4c9e0f0df
DIST elementpath-4.2.0.tar.gz 325076 BLAKE2B 662154d0869d7572ce95e99dcf5ea73e08374aef1a5d6a1e8830b6edeb2dfe949db939d72c18ec71d44a6a3b283375c6bef9731f2c6550bab591f9e62f21b74e SHA512 0d8fac41dc9246eccb67ed28f16eaf6fed28a78b53c6c0e1d46a964d2c264aa9f4dd2fa1bb3edd7f89846de3dad57e5e0d8b4aa31a9d39e1245e4baf94323589
+DIST elementpath-4.2.1.tar.gz 326745 BLAKE2B 63e5d92117a0ea25ad8aaeb14c99ce739b25ee4733366373098920c14e457fbee7b87398809913356a694812da5213936d783c60a1f7e2885d4dab49c2daf76f SHA512 bb996ea64051e73c05be05eeb3f373ed12759f07cc19b1e332715cf8876a6753dedcaba5b8c4e052e75b0f59f2f0344abcd106ae0d8dc79a36654b6c4135a20b
diff --git a/dev-python/elementpath/elementpath-4.2.1.ebuild b/dev-python/elementpath/elementpath-4.2.1.ebuild
new file mode 100644
index 000000000000..fb96a128f43a
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}