summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-10 08:35:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-10 09:06:05 +0200
commit488a314fe44c4b89561f66a1cf67711049247247 (patch)
tree0adf28d49b608ce2edd27c503ed65a31142a131b /dev-python/elementpath
parentdev-python/importlib-resources: Bump to 6.4.5 (diff)
downloadgentoo-488a314fe44c4b89561f66a1cf67711049247247.tar.gz
gentoo-488a314fe44c4b89561f66a1cf67711049247247.tar.bz2
gentoo-488a314fe44c4b89561f66a1cf67711049247247.zip
dev-python/elementpath: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-4.5.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index b87441466f5a..a17aab9a1ea0 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-4.4.0.tar.gz 330008 BLAKE2B 059b67c246052676b9514808dedad3b7dfa21a6e9291a52c9a56abb2d51e12fdf1271cd70978c83f861f76fc6d02a6b73180df7fb2e36a9c443ff344d13eb127 SHA512 ffa91ff55f893efed50620a0eae97dd0360f9eb80f264bd421a26215fe8fbcea715c1635465be3169c4d2be503a875f469b8507d12f8d44cb64f398accfd2750
+DIST elementpath-4.5.0.tar.gz 338727 BLAKE2B d05f98c509fb7d6fc2db73880963e8f77fbc4643907b6de37771bd52faaf054dddd9bfc35e238e4f8f7b4e0d3c033f4be9297e93b91462cd21664e16661739c4 SHA512 dafd480778d9d4e9fec1dc11d298590d460ad6b26f3683dea301b650da1b1ddcf03a68af6f3fa947b78a528f458ecf655e6ec172fd6ff194890c3f8fa28f37ca
diff --git a/dev-python/elementpath/elementpath-4.5.0.ebuild b/dev-python/elementpath/elementpath-4.5.0.ebuild
new file mode 100644
index 000000000000..c1ffc06d9ea7
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # fails for some reason, more fit for upstream testing anyway
+ tests/test_typing.py
+)