summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-10 07:52:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-10 08:32:38 +0100
commit4fe5c2f2b4764fc1eac997058d5c57d32302887f (patch)
tree987f5a8f9876137a594881a397df51b8d26b31e9 /dev-python/elementpath
parentdev-python/proto-plus: Bump to 1.19.8 (diff)
downloadgentoo-4fe5c2f2b4764fc1eac997058d5c57d32302887f.tar.gz
gentoo-4fe5c2f2b4764fc1eac997058d5c57d32302887f.tar.bz2
gentoo-4fe5c2f2b4764fc1eac997058d5c57d32302887f.zip
dev-python/elementpath: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.4.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 3731c91e5040..98123f4157aa 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-2.3.2.gh.tar.gz 239680 BLAKE2B 8e30a24dfbf2e1981ff0a199728d16c89214b70dfa195e8df338c762ba4ddda28936de30546809226bd080234185d44f6f45902e9ff561a12d56748c4500cd82 SHA512 4bedb2da3a139c35d12b0a41983ca50fabc2f653824c3dbc18cbc3024e666405586fdd8788ba7ecdcd55c70e75eb8bec9623839f015930d0f0a65fec10986b23
+DIST elementpath-2.4.0.gh.tar.gz 243871 BLAKE2B 1a16fa97a93a8a981c71d83a406353b5b002ea4fd814f177b7abff86ed0875770788737dc69843920cee1cc457b9a16859e6b1f4fd29889e3bf4d11b5b766621 SHA512 887a108b5de24a9be3dd1c577c623cf96939752f7c293d941e3b0bed4281d38a8edccf82fef9be8ee94bda7674f68ed17d3a060f803dcafce96e45961852ca24
diff --git a/dev-python/elementpath/elementpath-2.4.0.ebuild b/dev-python/elementpath/elementpath-2.4.0.ebuild
new file mode 100644
index 000000000000..a236efdff839
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest