summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-03 07:49:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-03 08:19:17 +0100
commit521e46a195a9bb4f4acd2a965b447dd34faeb875 (patch)
tree284f29dd4d24f9830fed8f2ade2d95d9085c1d61 /dev-python/elementpath
parentdev-python/jupyter_server: Bump to 2.2.1 (diff)
downloadgentoo-521e46a195a9bb4f4acd2a965b447dd34faeb875.tar.gz
gentoo-521e46a195a9bb4f4acd2a965b447dd34faeb875.tar.bz2
gentoo-521e46a195a9bb4f4acd2a965b447dd34faeb875.zip
dev-python/elementpath: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-4.0.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 578f593189bf..c50241bf192b 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,2 +1,3 @@
DIST elementpath-3.0.2.gh.tar.gz 275843 BLAKE2B b5e51971dbbcf68f6199ecf8d3270d2ed06732e3d1abc07d768127bc8a4cef4096fe3e6fe97606bde6d229753a942abd6c0019708f86e8a9931bc902bc8f48ef SHA512 46392cece136bd6e73285333b14a00ebbebcca70c7df42cd04021225207593ef33337fd468c12f089030f2a8adc1251660ebf762aa17f82b2f26ba902d6e89d2
DIST elementpath-4.0.0.gh.tar.gz 304721 BLAKE2B a3ad9a3f7746bd8d1df14d6057508b1db48e057ee83ff2d4278b4b1ffd2828ab96572780c4ee37b444eae49747a2008aa5133492dfeec762a134c8e4635e4bf3 SHA512 14f1b9f13212e935fcd7074ab2e0da7e3f43ac676e1c05b931eb1304f5eba951c0b2caa57f5eb04e006fa274a47ec2a0e42518023d4e8111b6795175b6ed8ede
+DIST elementpath-4.0.1.gh.tar.gz 305205 BLAKE2B 0de825213e91c5eb51b8b07973a311e982c0812180ac6bf79ac3357c7a747ff25b2126c5687a71fc06a619309749aee518ecf18bfa64335e0a5a93249579dace SHA512 22f76c028e665282fb81a99939c870c742461f5a107788fde398e88d4e59850161a4a7ab3159ce01076933cf211fcc4ec3e5727719e10520978ba33c9a13903d
diff --git a/dev-python/elementpath/elementpath-4.0.1.ebuild b/dev-python/elementpath/elementpath-4.0.1.ebuild
new file mode 100644
index 000000000000..ae27d9afd944
--- /dev/null
+++ b/dev-python/elementpath/elementpath-4.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}