summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/embedly
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/embedly')
-rw-r--r--dev-python/embedly/Manifest2
-rw-r--r--dev-python/embedly/embedly-0.4.3-r1.ebuild27
-rw-r--r--dev-python/embedly/embedly-0.5.0.ebuild25
-rw-r--r--dev-python/embedly/metadata.xml9
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/embedly/Manifest b/dev-python/embedly/Manifest
new file mode 100644
index 000000000000..bf0ca5497b47
--- /dev/null
+++ b/dev-python/embedly/Manifest
@@ -0,0 +1,2 @@
+DIST Embedly-0.4.3.tar.gz 6702 SHA256 e12e32bf600538e4dc8d0e4ea5c5f8e91b58ac21dc7c14168a16e16db0e7d812 SHA512 3e5d0d0389105c6beadf397da0d42238d56b831644e61f3c915307c57661210970c967c9babd84c0609a1e7ed3e2640ae60d46c4cf3f764596a4e1acc188c532 WHIRLPOOL 68d7eaed4ccd2f6b2de5f2a86f569c2c6d4af2656988cc289a178462becd20224d10ae8224e364d1707c6999b321c9050c831c341de2c07dd6143f7ebca451be
+DIST Embedly-0.5.0.tar.gz 7812 SHA256 e10bca4b5e25e8f30e93eb459921f787b08efc4004b6370a68f4c8984f6f16e1 SHA512 c85abacaa33b7897ccda79dc3746497f4eefe54bac3eef0aaa7c9120fec14ff6b7652a342303bea0667f60c2e31cb1591a22cddeff6827c87c6e2b1cc3274469 WHIRLPOOL b9a53ec896a4656404878473df9794163b4c792313636e077b90c991df18245dac32ebc109c08eb770c18ca3b9d0529bd03785ec7c6f12b70355e7f483cd8539
diff --git a/dev-python/embedly/embedly-0.4.3-r1.ebuild b/dev-python/embedly/embedly-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..784d2b6a820c
--- /dev/null
+++ b/dev-python/embedly/embedly-0.4.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Embedly"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python Library for Embedly"
+HOMEPAGE="https://github.com/embedly/embedly-python/ http://pypi.python.org/pypi/Embedly"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/embedly/embedly-0.5.0.ebuild b/dev-python/embedly/embedly-0.5.0.ebuild
new file mode 100644
index 000000000000..82da33df0e53
--- /dev/null
+++ b/dev-python/embedly/embedly-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Embedly"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python Library for Embedly"
+HOMEPAGE="https://github.com/embedly/embedly-python/ http://pypi.python.org/pypi/Embedly"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+# Testsuite relies upon connection to various sites on the net
diff --git a/dev-python/embedly/metadata.xml b/dev-python/embedly/metadata.xml
new file mode 100644
index 000000000000..c097ac690861
--- /dev/null
+++ b/dev-python/embedly/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Embedly</remote-id>
+ <remote-id type="github">embedly/embedly-python</remote-id>
+ </upstream>
+</pkgmetadata>