summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 10:44:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:08 +0100
commitd4624d1fb654d53040c183df47a27bac72dc5c1a (patch)
treec52df55812da86b4e3a0d3b3deaee4130fb973c4 /dev-python/environs
parentdev-python/pytest-httpx: Bump to 0.20.0 (diff)
downloadgentoo-d4624d1fb654d53040c183df47a27bac72dc5c1a.tar.gz
gentoo-d4624d1fb654d53040c183df47a27bac72dc5c1a.tar.bz2
gentoo-d4624d1fb654d53040c183df47a27bac72dc5c1a.zip
dev-python/environs: Bump to 9.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/environs')
-rw-r--r--dev-python/environs/Manifest1
-rw-r--r--dev-python/environs/environs-9.5.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/environs/Manifest b/dev-python/environs/Manifest
index 00c3212ae80d..6fdf1d67bb1f 100644
--- a/dev-python/environs/Manifest
+++ b/dev-python/environs/Manifest
@@ -1 +1,2 @@
DIST environs-9.3.4.gh.tar.gz 22914 BLAKE2B b47df2f7641ad47b48a0d4aaaaa0ce4fb2c805cefe6d997e5c6aa2ccfb2908196d879e251d496dda5ca9d112e1d2e60dd543f1ff62b7ad82ae5d546847aceef6 SHA512 b06110071ca423c6c6bdab8cb104dbc372cce77dcb057204b0b8c404827daeebfe72325d6d978bb4920c1b106af790b206b5d8a33f99bcbe31da4f82d4512006
+DIST environs-9.5.0.gh.tar.gz 23614 BLAKE2B 118305f7d6d2906beff69aa028449f8a5f6eba7815ec63972593dd43930802b5d1bd60457edc9803ed8ad216ae8feaad0d77fc03cd21e9883c40dc6656b1102e SHA512 8a73f9f89efe4d72b9a7a5a48b21ccaafcf32d59a6153c7cfa1c91d90a3a8a75e6c05d0ff0fecb94f593008dfff4c3534195f258391cee8fb720ee93c4f42812
diff --git a/dev-python/environs/environs-9.5.0.ebuild b/dev-python/environs/environs-9.5.0.ebuild
new file mode 100644
index 000000000000..e9dcccc50272
--- /dev/null
+++ b/dev-python/environs/environs-9.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for simplified environment variable parsing"
+HOMEPAGE="https://github.com/sloria/environs"
+SRC_URI="https://github.com/sloria/environs/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest