summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-02 05:04:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-02 05:04:43 +0200
commit043bf5daeb6766cb0ab1e181b6298aa469b2c36c (patch)
tree4215de370dc2dbd2d337f654ba11609571f5a31b /dev-python/fido2
parentdev-python/requests-toolbelt: Bump to 1.0.0 (diff)
downloadgentoo-043bf5daeb6766cb0ab1e181b6298aa469b2c36c.tar.gz
gentoo-043bf5daeb6766cb0ab1e181b6298aa469b2c36c.tar.bz2
gentoo-043bf5daeb6766cb0ab1e181b6298aa469b2c36c.zip
dev-python/fido2: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-0.9.3.ebuild53
-rw-r--r--dev-python/fido2/fido2-1.1.0.ebuild44
3 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index d89c11e733ff..320dcb4520e0 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,3 +1,2 @@
DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
-DIST fido2-1.1.0.tar.gz 243526 BLAKE2B 48a6466c1ad3723d3d5f2e22ef59b4b49ebc3231739ffffdb25349d466c23f5cdc063908ea1adb944041f646d0bd0648d66acdaae0e72a9715e4bc365f449c12 SHA512 df7fcf205a5c124daf14c4bb7742aa16def1e912490c3b967dd940fdb21baf1a933130eab276af7c03fb46fb779a5a2b8e5fa3d8e3cd379297c23d9f39cadba4
DIST fido2-1.1.1.tar.gz 247150 BLAKE2B 136d539db8bcaa5398e7ac2c2d0733c902b370c1b30491181164cc2f329c44dd81a42f19374ff6bd89fc757fe33580ef39bdb016e9f93f5ea17b12f22143761d SHA512 8078acbc85e277ddbf7a508f17c34f581eb8978786b5e43b4ede7de24138f07eee7f81aa307295305a42b286900a73903f269afd2a66aee9650fe05ac6aa1901
diff --git a/dev-python/fido2/fido2-0.9.3.ebuild b/dev-python/fido2/fido2-0.9.3.ebuild
deleted file mode 100644
index f9f736400d4c..000000000000
--- a/dev-python/fido2/fido2-0.9.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python based FIDO 2.0 library"
-HOMEPAGE="https://github.com/Yubico/python-fido2"
-SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
-SLOT="0/0.9" # Bumped every time a backwards-incompatible version is released
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
-IUSE="examples"
-RESTRICT="test" # Tests require <dev-python/mock-4
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyscard[${PYTHON_USEDEP}]
- examples? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-# Disable tests, <dev-python/mock-4 doesn't exist
-# DEPEND="${DEPEND}
-# test? (
-# ${RDEPEND}
-# <dev-python/mock-4[${PYTHON_USEDEP}]
-# >=dev-python/pyfakefs-3.4[${PYTHON_USEDEP}]
-# )
-# "
-#
-# When tests are available again, remember to add a custom
-# test phase that runs 'python -m unittest discover -v'
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r "${S}"/examples/.
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}
diff --git a/dev-python/fido2/fido2-1.1.0.ebuild b/dev-python/fido2/fido2-1.1.0.ebuild
deleted file mode 100644
index bf17632b1a20..000000000000
--- a/dev-python/fido2/fido2-1.1.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1
-
-DESCRIPTION="Python based FIDO 2.0 library"
-HOMEPAGE="
- https://github.com/Yubico/python-fido2/
- https://pypi.org/project/fido2/
-"
-SRC_URI="
- https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz
-"
-
-LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
-SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/cryptography-40[${PYTHON_USEDEP}]
- <dev-python/pyscard-3[${PYTHON_USEDEP}]
- examples? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r "${S}"/examples/.
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}