summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 11:07:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 11:59:01 +0200
commitd63e3358a248ce6c901af24410090f1b83f0c5c1 (patch)
tree792dbc2c92756d695f3be2c9d4610b30ba48ead9 /dev-python/filelock
parentdev-python/nbconvert: Bump to 6.5.2 (diff)
downloadgentoo-d63e3358a248ce6c901af24410090f1b83f0c5c1.tar.gz
gentoo-d63e3358a248ce6c901af24410090f1b83f0c5c1.tar.bz2
gentoo-d63e3358a248ce6c901af24410090f1b83f0c5c1.zip
dev-python/filelock: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.8.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 11b9421a2dd0..52b971446b60 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1 +1,2 @@
DIST py-filelock-3.7.1.gh.tar.gz 204373 BLAKE2B e3ef657488a68caf8dc8158d5060a07447b74b53b26a2ad05eb67211a5ae7ef5deadeb8527cb6cd95ce225e0fcd29a0ce2dd53b68b7e2cacde4c0f2242966b21 SHA512 66708398ae3c4dcd97a6031feca6a1b7d1010a5ee605c5adce29a9cfabe67c5464eefb3812c66e2c32c3547240fdc7acac6eec25cc8dfb2d5255079c5e6b44b4
+DIST py-filelock-3.8.0.gh.tar.gz 204748 BLAKE2B 719f965eddf9a76aaa7d3700ffbd29df3856fdcd76aa184b12a1e3b3341a5d8681f05ebd7239b48a0ffbc942aebc8574ff3878177100ba659347a904945b2234 SHA512 a9b63ab9a6697334eb8c561c422e8ec6febd0b7b203c0ebb4cfd1e4281f16cc0ef5145121c90f3c08bec88f13e219c0655142e3d3f856163702a0d32e14cd5ce
diff --git a/dev-python/filelock/filelock-3.8.0.ebuild b/dev-python/filelock/filelock-3.8.0.ebuild
new file mode 100644
index 000000000000..21f576cb0e32
--- /dev/null
+++ b/dev-python/filelock/filelock-3.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+SRC_URI="
+ https://github.com/tox-dev/py-filelock/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}