summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-31 08:22:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-31 08:55:02 +0200
commite377c684b3f728f50fb67442bc5d1e4152967c92 (patch)
tree7fe08d836ca9ade92e549e216d6b88bdbf02ee08 /dev-python/flask-cors
parentdev-python/pydantic: Bump to 2.9.0_beta2 (diff)
downloadgentoo-e377c684b3f728f50fb67442bc5d1e4152967c92.tar.gz
gentoo-e377c684b3f728f50fb67442bc5d1e4152967c92.tar.bz2
gentoo-e377c684b3f728f50fb67442bc5d1e4152967c92.zip
dev-python/flask-cors: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-cors')
-rw-r--r--dev-python/flask-cors/Manifest1
-rw-r--r--dev-python/flask-cors/flask-cors-5.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flask-cors/Manifest b/dev-python/flask-cors/Manifest
index 20195edb349a..f8c6e71aa80a 100644
--- a/dev-python/flask-cors/Manifest
+++ b/dev-python/flask-cors/Manifest
@@ -1 +1,2 @@
DIST flask-cors-4.0.1.gh.tar.gz 32226 BLAKE2B f6301842b20175587be43d3c1f22fb341463f25d21fcae9b6463e8c48b149ab7ddf000d5541645f217755bc43863ef060cf1e2f6e57941632db420efb1cd223e SHA512 51dd7c50d5db6a6b6985a32f08f9512603e64199bf90dd22349cd1dbff94f1706b1e26cbe7765fb6dc6310fce86ac470896b127dc83cc740436e1ae11c11f7eb
+DIST flask-cors-5.0.0.gh.tar.gz 32891 BLAKE2B 0315f37fdd10d6000c8b5613a9b8616df5db1009e23614a68e430979888ead49c20174cde0e4f1a1019b455cac868b113bf09f0c004552cc452a12e1840764d3 SHA512 36cff5f9d9a3692a794510b431ad1889931e9d09c569078ab604e4b6b0777139afb10063f851f2e64d76ae6441444ada4a04855f8578a78bb5d3aabdf346e0de
diff --git a/dev-python/flask-cors/flask-cors-5.0.0.ebuild b/dev-python/flask-cors/flask-cors-5.0.0.ebuild
new file mode 100644
index 000000000000..0486dac2f707
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-5.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/corydolphin/flask-cors.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/corydolphin/flask-cors/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="A Flask extension for Cross Origin Resource Sharing (CORS)"
+HOMEPAGE="
+ https://github.com/corydolphin/flask-cors/
+ https://pypi.org/project/Flask-Cors/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-httpdomain