summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2019-03-03 14:27:21 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-10 23:35:10 +0100
commite6a7a8c0209a939de7368498494c094e92d381ed (patch)
tree681eed62a083c84a6f20d86a4d7e405ed6e8515f /dev-python/flask-paginate
parentnet-p2p/go-ipfs-bin: version bump to 0.4.19. (diff)
downloadgentoo-e6a7a8c0209a939de7368498494c094e92d381ed.tar.gz
gentoo-e6a7a8c0209a939de7368498494c094e92d381ed.tar.bz2
gentoo-e6a7a8c0209a939de7368498494c094e92d381ed.zip
dev-python/flask-paginate: version bump to 0.5.2.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11229 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.5.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index 9b484e21a943..9b6d59f4d81a 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1 +1,2 @@
DIST flask-paginate-0.5.1.tar.gz 5397 BLAKE2B 819740f6d1ff55331932dfb1a588fb0a92b2a6ffbf66c0ffcedddb2014c42c10f76ce50306fb9e389c66fdeba98fbf0d476915e935530bfeecc853ec25c1f9d4 SHA512 f17610cc3861d587e1940a69957a9266459270453d8f7c15ae6b6e5fa91633194e01384b1cec98647db70f38090d18fd44bf2fc4cbbd8d1d64cf541a5bd620c2
+DIST flask-paginate-0.5.2.tar.gz 5535 BLAKE2B c343fdbd04097ccbf187f7a0aa127157fd18e39e68c6ca6dfee0e30a31f6e6b25bac4f2d64cf7a88b4c9addb53e45f381146f9710d84335ceb684198ad164372 SHA512 03cdce455f64da226a64137c3a69fda23749280e52df5d4fc4850e816c38810519a2f5a79bdd06709fc686ff413bcbc4a1bf20da44eba7678c5f3e542c277037
diff --git a/dev-python/flask-paginate/flask-paginate-0.5.2.ebuild b/dev-python/flask-paginate/flask-paginate-0.5.2.ebuild
new file mode 100644
index 000000000000..ffbe17e5d8fb
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-0.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ ${DEPEND}
+ dev-python/flask[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}