summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-03 10:13:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-03 10:13:44 +0100
commit03f17e9efbfa38149245753bea2bc14f40ef5650 (patch)
tree8b3ccccf280b792f8d2fd2d255919cd242e288f0 /dev-python/flask
parentdev-python/pandocfilters: Remove old (diff)
downloadgentoo-03f17e9efbfa38149245753bea2bc14f40ef5650.tar.gz
gentoo-03f17e9efbfa38149245753bea2bc14f40ef5650.tar.bz2
gentoo-03f17e9efbfa38149245753bea2bc14f40ef5650.zip
dev-python/flask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-3.0.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 79f6b060f6a7..75d1d7d1dee0 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,3 +1,2 @@
DIST flask-2.3.3.tar.gz 672756 BLAKE2B 70feb2f1ec8bc4742e8da978b7e1063c5f0bcbfda5321f397cba121283376b5b10a275635eac76383945415dbba3b2c4f917e1495851ee1dfd745db97caddec5 SHA512 801b2521c42de7a4cd16005ea6ea7737aaef6c88edacb38ab03e2d78bb4e080e35e540c23e157e2bcdb43e4818b4b7a856c50c6cf41bb17f0b7b2590c0c6aff2
-DIST flask-3.0.0.tar.gz 674171 BLAKE2B 5ae270b429d6ea344828bead0cab855b42f4c28821c843a7754f4741ef0320c190e386a08adb4c6a5018e6a2cc7be588d955ebd4edf31ae59ea9d511c9cd93cb SHA512 dab4f97909619e380e9d8f14cea346dbda8932f3e9d19ee45e3651faf51b94aa5ccaa658116c69abae680f5357235842c63f0c6ff2a191de70cc103f0e7624a4
DIST flask-3.0.1.tar.gz 675138 BLAKE2B 974eda07aa3c8d679495d34ac0d3c64a5aa2318c8675a52817068c2eeb3b90c7da07800230b18df0767329f15670b72ed4fe8fa6e4737ad00e842cdd9aa77adf SHA512 ae1f191b965b548e6f390b61ea1219b3399f773a1667d28aef63fcd4ab0f82d3eac9a430be43488ea01aa82a12d5677b3f6a5a48b8cce6c7204bf386d4c3f6f2
diff --git a/dev-python/flask/flask-3.0.0.ebuild b/dev-python/flask/flask-3.0.0.ebuild
deleted file mode 100644
index 6c3bd0625c7f..000000000000
--- a/dev-python/flask/flask-3.0.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="
- https://palletsprojects.com/p/flask/
- https://github.com/pallets/flask/
- https://pypi.org/project/Flask/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- inherit pypi
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/blinker-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.1.2[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-3.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- !!dev-python/shiboken2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinx-issues \
- dev-python/sphinx-tabs \
- dev-python/sphinxcontrib-log-cabinet
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}