summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-21 19:27:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 19:48:48 +0200
commit0182309dcb5bfee7b75b9c3b1bd49ad944579071 (patch)
treef70bb977cbe8110dc642d9acb61f8d7edb6d4963 /dev-python/fs
parentinstall-qa-check.d: Account for setuptools in requires.txt (diff)
downloadgentoo-0182309dcb5bfee7b75b9c3b1bd49ad944579071.tar.gz
gentoo-0182309dcb5bfee7b75b9c3b1bd49ad944579071.tar.bz2
gentoo-0182309dcb5bfee7b75b9c3b1bd49ad944579071.zip
dev-python/fs: Set DISTUTILS_USE_SETUPTOOLS=rdepend
The install-qa-check.d has been improved to handle rdepend from requires.txt, so it gets this package right now. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.11.ebuild5
1 files changed, 1 insertions, 4 deletions
diff --git a/dev-python/fs/fs-2.4.11.ebuild b/dev-python/fs/fs-2.4.11.ebuild
index a71c92e9647c..f6e3a9fe0981 100644
--- a/dev-python/fs/fs-2.4.11.ebuild
+++ b/dev-python/fs/fs-2.4.11.ebuild
@@ -6,8 +6,7 @@ EAPI=7
# Not yet ready for 3.9
# https://github.com/PyFilesystem/pyfilesystem2/issues/421
PYTHON_COMPAT=( python3_{6,7,8} )
-# pkg_resources is used
-DISTUTILS_USE_SETUPTOOLS=manual
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 optfeature
@@ -32,10 +31,8 @@ RDEPEND="
>=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/pyftpdlib[${PYTHON_USEDEP}]